Fitting a microhard on the Bixler

So I'm currently trying to fit a microhard n920 onto a Bixler, and unfortunately I don't see a way to do this without also having the dev board (doesn't look like they have a small breakout board I can wire up to).  I've managed to get it to fit into the fuselage, but don't see a way to connect the RS232 to the TTL converter. Anyone have a solution or know of some RS232 angle adapter that might work?  Alternatively, is there a way to wire this using the RS485/422 pins?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hallo,

    I forgot to mention that in the last few months I've been prototyping a new board using a transceiver from TI (CC1200) the results are surprinsing! With a very narrow bandwidth (11kHz @433MHz) and a form factor that's comparable with n920 units  we achieved 17km range with just 14dB of emitted power (using standard omni-antennas). Of course with such a limited bandwidth you'll have just 1200bps stream but you can sacrifice range and gain bandwidth. The only problem is that the component is not a serial transparent modem but just a transceiver than an interface management microcontroller should been interposed. Let me know if you are interested.

    Bes regards,


    • Hi everyone please note that escape codes lire +++ are not peculiar of Microhard units but it is common to every AT modem (99% of modem units on the market ) such codes are commobly rejected after a certain delay from powerup . Besides that you're not requested to manage escaping when dealing with a modem (if needed is done by the protocol manager itself)..... so just don't care.
      • Hi Michele,

        I need to correct you on this. 

        Microhard modems don't have any set timer to enter in command mode, therefore at anytime into the data streaming, you can request to enter in command mode. 

        Page 61 of the Microhard Nano operational manual describes the issue, and how to fix it. 

        I'm well aware of this potential issue, as I experienced that with the N920. Modem was loosing link and settings randomly.  After being probed with a logic analyser I found the issue.  random appearance or the +++ on the binary data streamed on the telemetry. 

    • Hi

      nice job

      can you please give me more detail about your job. was it to connect pixhawk to mission planner

      thank you


      • What do you mean?

      • Hi Mohsein,

        Please note that using the microhard modems you might encounter an other issue, that you have to fix before you can use them reliably, and is possibly the reason why you can't get them to work. 

        MAVlink is broadcasted in binary therefore when interpreted form an ASCII terminal you have all random characters. The microhard nano series has an escape character ( set to ascii " + "), so when streaming data in binary, a random "+" character will send your modems in configuration mode. 

        You need to disable the escape character by setting a value above 127 in the S2 register ( refer to page 85 of the manual ), and you need to do this for both modems. 

        After you have done this, you need to verify that the modem will not go into configuration mode when you digit "+" 

        Hope this helps 

        • Hi naish

          thank you for your concern to the subject

          actually I am away from the lab for afew days. but your recommendation seems smart and I will take it as I go to the lab.

          I will let you know the result

          thank you so much


    • Hi dear Michele

      I want to connect pixhawk to gcs via n920 telemetry link. when we test this link separately with serial terminal it works good and can send and receive data perfectly but when I connect it to the pixhawk it can not connect it to the  mission planner and gives time out error.

      would you please help me in this way

      my email is

      thank you so much

This reply was deleted.