Whats up yall. So there will be profanity in this post. If you have small children have them look away now.

I am on my last wit here. If this cannot get fixed, I will post a video of me blowing up this f*****g quad in some shape or form. All work Flawlessly and the issue came out of absolute nowhere.

So............. New Motors, New ESC's, ALL new wiring. Only the bare essentials connected. Reinstalled Pixhawk firmware. Re-Flashed pixhawk. Re-Flashed Devo Transmitter. Tested quad with pre-arm off. Re calibration of pixhawk. Tried again. Removed power module. Powering pixhawk with 5v leads from ESC's.

The quad cannot leave the ground......It seems as if the quad is EXTREMELY under powered. When at full throttle, the thing runs for a few more seconds, then a full blackout. I mean FULL blackout. ESC's, Flight Controller. even with the battery connected. To power back on, The battery needs to be unplugged and plugged back in again.

PLEASE PLEASE PLEASE PLEASE PLEASE help.....................................for god's f*****g sake.

P.S. I intended on using more profanity.....

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

    • as someone who has learnt the hard way over and over again, it is very rarely worth it to buy a cheap clone and save a few bucks at the expense of spending hours, days, weeks trouble shooting.


      If you work out your hourly rate at mucking around, it soon pays to just do it properly the first time.


      Some people have had no issue at all with those clones, but other's have had no end of trouble.

      • +1, swap in a APM 2.6 clone and see if it happens otherwise it sounds like a faulty Pixhawk clone; good luck on the refund ;)

    • I think that is correct that the rail on the Pixhawk is not powered. I have seen in documentation that if you need to power a servo, you also need to provide power to the rail for that. The rail ground is connected to the rest of the PH system, though I don't think it is rated for very much current, as that should be sinked by the external power.

      • So that rail shouldn't have 5v across the whole?....

        • MR60

          The rail provides 5V but with very limited amperage. When it is said to add a BEC on the servo rail, this is just to cover the amperage needed by devices connected on it, like servos. But if you just have a receiver, Pixhawk's rail provides enough power.

          About your issue, it is certainly your board is faulty. Try another one to confirm this and as Chris said, beware of clones quality that can be good but also bad.

          • Yup, it's right that there is no 5V along the middle rail of the pixhawk. As per documentation, only the RCout is powered.

            If the board totally shuts off when you apply full throttle then it has to be a power problem. I don't understand how a faulty board would cause this. 

            So when you check the 5V on RC OUT before, during and after the full throttle - what do you see?

            • there is no voltage across that RCout. and by RCout i assue you mean the main out section?

              • Do you have a multi-meter.
                Just trying different things doesn't usually solve a problem.
                You need to measure some voltages and currents from various places when you fire up and actually experience the problem.

                For example, does the voltage to the pixhawke drop when you power up the motors or does it remain constant.

                Have you tried doing a motor test, can you power up individual motors to high speed ok, or is it only when all of them power up.

                What is the current drain on your battery at idle and when you power up?

  • Have you tuned the PIDs at all? That might be hard to do with the power not working, but check the initial PID settings and see if they are too low to allow it to move. I had an issue that caused autotune to lower my PIDs to levels so low that it couldn't even hold itself off the ground.

    • At this point  I don't think it's a programming error...Some power test prove some funy shtuff is going on within the pixhawk RC rails. 

This reply was deleted.

Activity

DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Monday
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: Another incident: https://t.co/G1pTxQug6B
Oct 23
More…