Whats up yall. So there will be profanity in this post. If you have small children have them look away now.

I am on my last wit here. If this cannot get fixed, I will post a video of me blowing up this f*****g quad in some shape or form. All work Flawlessly and the issue came out of absolute nowhere.

So............. New Motors, New ESC's, ALL new wiring. Only the bare essentials connected. Reinstalled Pixhawk firmware. Re-Flashed pixhawk. Re-Flashed Devo Transmitter. Tested quad with pre-arm off. Re calibration of pixhawk. Tried again. Removed power module. Powering pixhawk with 5v leads from ESC's.

The quad cannot leave the ground......It seems as if the quad is EXTREMELY under powered. When at full throttle, the thing runs for a few more seconds, then a full blackout. I mean FULL blackout. ESC's, Flight Controller. even with the battery connected. To power back on, The battery needs to be unplugged and plugged back in again.

PLEASE PLEASE PLEASE PLEASE PLEASE help.....................................for god's f*****g sake.

P.S. I intended on using more profanity.....

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


      • Moderator
        Almost right, you also told someone who was trying to help you that he didn't know what he was talking about (you are free to ignore help of course) but instead decided to be antagonistic. To finish off you also had a go at his spelling when it is clear that he is not a native English speaker, I would not like to give technical advice in another language let alone be chastised for spelling mistakes- very disingenuous. Still, if you are happy with your behaviour please feel free to critisize.
        • @Martin Truran

          I'll concede your point that I was antagonistic but were his responses and generalisations really attempts to help coming from an obvious lack of knowledge and experience or were they just posts for posts sake?

          However, I will take issue with suggesting that I criticised his spelling. My quotes were about substance not spelling and nothing I said suggested otherwise..

          Anyway, back to the bun fight here, sorry that I was provoked to defend myself on this topic rather than the actual topic..

          • Moderator
            Even if, and it's a big if, you did not rate his advice there is still no reason to belittle someone who is trying to help you on this forum- so your concession is correct (although the apparent justification wildly misses the mark). So your comment that finished your riposte "by the way, what is a cuad?" When it was blatantly referring to a quad was not a criticism?
            If is not enough that your comment was moderated, then the fact that the immediate reply from another member was to proffer the opinion that it was disrespectful and unwarranted may give you a clue as to how it was taken. As for the apology you posted, it is not really an apology when you go on to try and justify the original offence.
            We are a community, people here try and help in their own time and for no reward- should we not be grateful for any assistance?
            • I don't want to add any further clutter to this already cluttered topic Martin so I will reply to you a little later on the topic that you are criticising me for.

              • Moderator
                There is no need on my part Peter, your assertion on this thread has been addressed. You need not acquiesce and I can see no justification that would suffice.
                • I'm not sure that my initial assertion has been addressed by anybody of import Martin but I'm happy to acquiesce..

  • Hello Shaheen or should we call you J. SMITH....f..k of from this forum...f..k of with your big letters,and go testing somewhere else!!!!!!

    3DR can we do something to stop this BS in the future?

  • As this issue seems to be related to load maybe the lipo is faulty. Although I don't see why the pixhawk wouldn't powerup after a brownout.
    Do you have a way to measure the internal resistance I.e as part of your charger? Even a basic voltage check across battery when not connected then when running 3 motors.
    • The batteries seem healthy to me...and i thought it was a lipo issue at first because i accidentally left one charged over 24 hours (which I thought the rule of thumb was no more than 10 days) but then ordered 2 brandy new shiny ones and same issue. I would hope i don't have $240 worth of virtually new junk batteries o.O

      And besides, I've seen the Pixhawk brown out, and it usually does power back up again. I am talking full Pixhawk blackout until i disconnect and re-connect the battery.

  • So Here is something interesting....There is no voltage going thru the positive and negative rails on the pixhawk other than the SBUS in array going to the reciever. If, i am correct, there should be voltage across the entire rail if powered via the power module to the power input on the top of the unit correct?

    In this case, this could be causing that ground loop issue you mentioned earlier?

    I would also like to take this time to thank you all for helping me get closer to closure. I contact the seller that I ordered the PH from and he is sending a replacement (1 year warrantee claimed on his page). . I just want to get to the bottom of the actual cause of this problem.

This reply was deleted.


David Hori liked Isabella Domi's profile
gotham liked gotham's profile
Dec 3, 2020