in the groundstation server screen data is comeing in good but the gps data is all zeros. im useing your ublox satelite adapter and your board to attach to the arduimu. i checked all my code and everything looks good but i cant get a lock. iv tried this all over not just in my lab room even outside i get the same problem. only thing i didnt check is if the ublox is configured correctly but i figured it would be becasue i got it from you guys. nt sure what other data i can give you just let me know. have attached a screen shot of my groundstation running

ps. lights all flicker on and off in series then it goes silent with just one green led on.

Views: 219

Attachments:

Reply to This

Replies to This Discussion

Shawn,

Several people have had trouble getting a lock and there are a couple known issues.

What firmware are you using? V1.1 has a known issue with the ublox. V1.2 is OK

The connector between the ublox module and the adapter board is really bad. If you have it "packaged" in any way that produces torque between the two the connector may not make good contact.

Worst case - hook up your ublox using the ftdi cable (there are directions here in the ArduPilot main thread somewhere) and use ucentral to see what is going on with the gps.
yea the connector seems to be ok.. im running 1.2. i will try out ucentral. not sure what that is right now but i will go find it.

thanks
You sure you are using 1.2? Not to argue with you but IIRC the cube was deactivated in 1.2, but I see it in your picture. It doesn't come up with mine. Anyway, did you setup the ArduIMU_DCM_V12 sketch properly? I highlighted a screen shot of mine. You need to print the DCM to get the visuals to work...

wow, small pic...

let me know if you can see that...
yea for sure im useing 1.2. you can turn the cube on and off with the button on the bottom right of the labview screen. im pretty sure im not getting a signal lock for some reason. i will try a couple things when i get home and let you know.
definetly has something to do with the gps. its runs the same with the gps disconnected and when it is connected. no signal comeing through. why this is happening im not sure for now. guess i will keep playing with it until i figure it out.
still no luck i have no idea. if anyone knows of a board out there that will let me interface the modual to the computer for use with u-center that would be the next step. cant seem to find one. sparkfun has a development boar dwill that do for this purpose?
well this post is not just a arduimu problem i cant get a lock on my adrupilot either. i used the sparkfun connection board to sync up with ucenter but even thats not working. im thinking my module is bad guess i will just buy another one and see if that works. only way to tell.
i decided to try uncentre one last time and pop it took the frimware update. it was dead before but i just retried and retried and finnally it took. so it appears fine in ucentre but i dont know what to configure on it to make it compatible with arduimu or adrupilot. slowly but surely getting there lol.
weird, I hit thsat button a few times, and the cube never shows, oh well...
I think there is some unused initialization code in ArduPilot. Take a look there for a starting point. Only thing I know is it is set up for a binary mode (not NMEA) and the baud rate should be 38400 (or whatever the standard value close to that is). I am not near my setup at present, but If you don't get it sorted in the next day PM me and I'll hook one of mine up to ucenter and see what the settings are.
Hello to all !!

I have both arduimu ver 1 and 2(flat one) + ublox GPS and adapter.

In virtual lab 8.5 ground test or processing ground test station I can see the imu working but I get only zero's on every GPS fields ( no lat and no long readings). The arduimu board is showing a blue led (gps lock) and a yellow intermittent led wich I understand is normal since I do not move and there is no yaw drift correction. I tried going outside under clear sky but no luck...still no GPS position reading. If I remember well I ordered the ublox ready for ardupilot.Could it be the reason for my problem?Any help will be greatly appreciated.

Thanks to all for your good work

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service