Hello again all, any help here would be much apreciated.


I am flying a droidworx octo HL and flown over 300 perfect flights with Arducopter since .42, now running .49


I've got GPS and SONAR, alt hold with sonar works great, but GPS is acting funky, our rig if purpose built for aerial photo/video (seen recent vid here http://vimeo.com/30957186) and been flying solid for a long time now, but never really messed with GPS, I've only recently put it on to play around and possibly have RTL as a safety feature.


When flying around for a while, then hovering and switching to loiter, it imediatly want to head left, and then does a massive ass circle shape, like 50-70m, this is not loitering, lol. Everytime i enable loiter it wants to do the same thing, at first i thought is was circle mode, but have checked and re-checked the modes, it's loiter, the logs also read as loiter in google earth.


The strage thing is that the logs show the exact spots where i am flying, very acurately in fact, but I don't get why it does not want to hold the spot, but instead fly off ???


Here what it does, before I quickly switch back to stab as it just carries on


the white dots are where i enable loiter.


My settings at loiter P 2 (have tried 1, and less, does the same thing)

Nav P all at defualt, can anyone give me some insight into this ? Is there a specific way the GPS must sit in relation to the APM board, direction etc ? I've changed it as well, same thing.


Any ideas ???



Views: 583

Reply to This

Replies to This Discussion

I think the problem is ultimately related to the magnetometer, or the way it is calibrated, etc. Can you check how well your magnetometer works?

GPS can sit in any direction.


Have you done the GPS test in the CLI?  Does it provide accurate coordinates?


There have also been some changes to loiter recently.  You may want to review the Git repo, and see if you want to try .50

i use simple mode quite a bit and the mag seems to be working great, how would i check if its correct?

I found that mine did some very odd things until I set DECL in the CLI - for some reason the CLI had a different value to that displayed in the Mission Planner.

THanks Mark, I've just checked the CLI and dec was 0.000 and my dec is 26.14233, so changed it and will test it out again this afternoon, thanks again for that!



Is it possible useing a Mikrikopter GPS with the Arducopter Mega+IMU boards instead of the stock one ?? I've got a spare MK GPS from our mk kit we started with (and happily moved onto ardu)


possible ?? It's got the same plug as the tek gps, maybe ?

Hey again, I've sorted out the issues I was having (missing a - for the negative declination lol)


So loiter is working but still creating fairly large circles, this screenshot is 25m form end to end, and gets bigger as the copter goes.


Any ideas what setting would work well, it's a droidworx AD-8 octo with camera mount, so pretty large, it flies rock soild but loiter could do better I think ?


Currently on default PID. Any suggestions ??



ALos, has anyone tried using the Mikrokopter GPS board with the Ardupilot Mega  kit ? I have a MK gps (LEA 6s Ublox) GPS and it also has the 5 wire plug , ideas ??

Did you get the Loiter circling fixed, I have the same problem with Loiter going in circles of about 10 m diameter, this is 2..049

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service