So I have noticed that my gps position is not updating in mission planner beyond the time of when I initially plug in the copter and it gets a fix, regardless of the position of the safety switch. I know it hasn't always been this way. It appears that after initial power up of the copter and first fix that the FC is not updating its position until the copter is armed. I know this because once I armed the copter it immediately started updating the position and triggering the camera because I had CAM_TRIGG_DIST set to 1 meter. Is there some setting to make it constantly update gps position once the copter is plugged in?

Everything is updated (V3.2.1 on Pixhawk) and the only thing I changed recently was adding a second GPS (ublox neo-m8n is primary and ublox nex-6m secondary). I have tried unplugging the second GPS and changing the switching setting to 0 and second GPS setting to 0. It still doesn't update.

I was going to start using the SwiftTag photo tagger but if I can't simply move the copter around and have it update gps postition to trigger the camera then I don't see a good (safe) way to get the initial picture you need to start the trigger script in MP.

Views: 95

Reply to This

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service