HELP! analyse the reason behind crash

Pixhawk Crash Analysis

 

Date:19-05-2017

Time: 4 – 7 p.m.

Weather: Calm, sunny day & with no or little wind

Temp: 37-32 C

Plane: Volantex Ranger

Board: 3DR Pixhawk loaded with plane 3.7.1

Battery: DIY 3s pack 20400Mah made from Panasonic ncr18650b

 

After programming the board, today was the first test flight. I took off in manual mode, trimmed the plane and flown it for almost 10 to 15 minutes in manual mode without any problem.

Then I switched to FBWA mode the plane handled the flight very well with the stock parameters and without any tuning at all. Then I switched to FBWB mode and the result was great flight. After that I switched to cruise mode where I faced only one issue: The plane was holding the flight path really well but with some roller coaster motion (something that I know is having to do with tuning). After that I switched to loiter and the plane started performing good circles thought I haven’t calibrated the airspeed yet. Only then and after making sure that the plane can fly itself I switched to RTL mode and the plane came back to me and started loitering at 200m altitude which I had set for RTL altitude.

Now it was the right time to start the auto tuning progress. I went ahead and did the roll tuning, then the pitch tuning and everything was good. After that I checked the tuning page on my mission planner and the parameters were changed to the new set of the auto tuning. Afterwards I started applying rudder inputs to tune the yaw and here the problem started. After few rudder inputs the plane stopped responding and went into a turn towards the ground with the rudder stock in one end. While the plane was going down I switched out of Auto tune and tried all the modes but without getting any response from the plane even in manual mode.

It was at that moment when the plane sat on the green field about 500 meters away from me. When the plane hit the ground the radio announced “RSSI CRITICAL”.

When I reached the plane opened the canopy the led indicator of Pixhawk was indicating failsafe. The plane wasn’t damaged at all and I didn’t notice any damage to the electronics as well. Of course I haven’t checked anything yet.

I had the screen recorder on my laptop recording the screen and now when I came to see the last seconds before the crash I realized few things that I wasn’t aware of as I had the sound muted on my laptop.

            

31’ 20”                    in to the flight                        started the yaw tuning

31’ 27”                    in to the flight                        3 yaw inputs so far

31’ 28”                    in to the flight                        bad AHRS

31’ 29”                    in to the flight                        error caused vert variance   

31’ 36”                    in to the flight                        6 yaw inputs and I realized that something is not OK with plane

31’ 39”                    in to the flight                        warning no data for 10 seconds

31’ 40”                    in to the flight                        changed to other modes

31’ 44”                    in to the flight                        earning no data for 15 seconds

31’ 46”                    in to the flight                        I was sure that the plane is not responding at all

31’ 55”                    in to the flight                        warning no data for 25 seconds

32’ 05”                    in to the flight                        RSSI critical (from Taranis)

32’ 08”                    in to the flight                        Telemetry lost (from Taranis)

32’ 21”                    in to the flight                        Telemetry recovered (from Taranis)

32’ 23”                    in to the flight                        Telemetry lost (from Taranis)

32’ 42”                    in to the flight                        No RC Receiver

                                                                                 Error caused vert variance

                                                                                 Bad AHRS

                                                                                 Error compass variance      

Same errors continued for several minutes till I reached the plane and turned it off.

                                                                                 Telemetry Recovered, RSSI critical, Telemetry Lost, ….

Now when I connect the Pixhawk to the PC I get a solid red light and I cannot get it to connect to mission planner.

I’ll try to go through all the components one by one to see if I can detect any error or issue starting from tonight.

Guys, please give me your thoughts and ideas on what could be the cause

Many Thanks

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • If we rule out the power supply as the cause, that would indicate a random component failure on the Pixhawk.

    Since you aren't using any non-3DR components, there would seem to be no other possible causes.

  • Well, all the components that I use are from 3DR. I don't use anything clone, so the Power Module is a genuine one and I've tested that as well as the GPS, the airspeed and everything else that was on the Ranger and all of that works fine. As for the backup power yes I do use the servo rail as a backup power and I normally power the servos from an outside power unit so all the power that comes to the board is being used by the Pixhawk and the sensors only. 

    Mark Whitehorn said:

    My guess is that the safety coprocessor, or a related component has failed. I'd replace the Pixhawk and make sure that its power supply is reliable, since there's a chance the failure was caused by a spike on the power input. Are you using the servo rail as a backup power source?

  • My guess is that the safety coprocessor, or a related component has failed. I'd replace the Pixhawk and make sure that its power supply is reliable, since there's a chance the failure was caused by a spike on the power input. Are you using the servo rail as a backup power source?



  • Tom Pittenger said:

    You suffered a power/hardware failure during flight. Have you considered you're suffering from a power/hardware failure now? Might be hard to get your replacement shipped to IRAQ though...

    Well, according to the log analysis result done by you guys it was a power failure. Now I have tried to power the board using a usb cable, the power module and the backup power from the servo rails but still the problem is there. The red light is on with a mix of tones at the startup.

    As for shipping the replacement I have connections in different parts of USA and Europe that the replacement can be shipped to.

    And again I have to thank you guys for your time and efforts

  • Yes I have tried every possible way that I found online including booting with the safety switch, but I couldn't get it to work.

    Mark Whitehorn said:

    Have you tried booting with the safety switch pressed?

  • Developer

    You suffered a power/hardware failure during flight. Have you considered you're suffering from a power/hardware failure now? Might be hard to get your replacement shipped to IRAQ though...

  • Have you tried booting with the safety switch pressed?

  • I've tried several different SD cards and even  different firmware yet I'm unable to get over the error. I've also search online and all the same errors remained unsolved except for few that did flash the Q Ground Control Px4 pro, a trick witch didn't work for me. I was wondering if there is any other reason and/or a solution to this error?

  • usually thats related to a bad or missing SD card

    Mohammed A. Shakir said:

    The problem that I have now is that I'm unable to get the pixhawk to connect to mission planner. The red solid light is indicating an error. I've tried to flash different firmware but nothing happened. I've tried flashing the px4 pro using QGround Control. It works and the solid red changes to blinking red and it won't go off.

    The BOOT file located on the SD card says:"no px4io board found"

    I've tried flashing the master firmware it works but still the error on the mission planer is:"no px4io board found"

    Any ideas on how can I solve the issue?

  • Here is the Tlog File.

    Many Thanks guys for your hard work and help

    2017-05-19 17-50-28.tlog

This reply was deleted.

Activity

DIY Robocars via Twitter
7 hours ago
DIY Robocars via Twitter
8 hours ago
DIY Robocars via Twitter
RT @breadcentric: Bingo card for AWS DeepRacer Finale, starting in 10 minutes on https://www.twitch.tv/aws ! #AWSDeepRacer #DeepRacer #Machin…
11 hours ago
DIY Robocars via Twitter
RT @NVIDIAEmbedded: It's #NanoFriday - the RB-0 uses the same suspension concept as #NASA's newer differential-bar rovers. This educational…
11 hours ago
DIY Robocars via Twitter
RT @chr1sa: On May 22, we're returning to in-person AI @DIYRobocar racing at @circuitlaunch. The Amazon @awscloud DeepRacer team will be pr…
Wednesday
DIY Robocars via Twitter
RT @breadcentric: On my CV: Hobbies: Training bananas to race on tracks #AWSDeepRacer #DeepRacer https://t.co/MKe14hNyux
Wednesday
DIY Robocars via Twitter
RT @breadcentric: See how the April AWS DeepRacer races have ended and a couple bits of news: https://blog.deepracing.io/2021/05/09/aws-deepracer-league-2021-update-11-end-of-april-special/ #AWSDeepRacer #Machin…
Monday
DIY Robocars via Twitter
RT @sunilmallya: Representation Learning +Instance Transfer to learn new reward functions along with advantage based filtering of new exper…
Monday
DIY Robocars via Twitter
Apr 27
DIY Robocars via Twitter
Apr 27
DIY Robocars via Twitter
RT @f1tenth: Sliding (autonomously) into the weekend like ... 🤖😎 #f1tenth #robots #AutonomousVehicles @OpenRoboticsOrg @NVIDIAEmbedded @Aut…
Apr 25
DIY Robocars via Twitter
RT @chr1sa: One of the problems with autonomous car racing is that watching software drive is not a very exciting spectator sport. To help…
Apr 25
DIY Robocars via Twitter
RT @SmallpixelCar: Replaced AGX Xavier with @NVIDIAEmbedded Jetson Xavier NX. Now both cars look fast and clean https://t.co/jlcoY2EjZf
Apr 25
DIY Robocars via Twitter
RT @chr1sa: Yesterday we had a record number of competitors (36) in our monthly @DIYRobocars virtual autonomous car race. We kept it going…
Apr 25
DIY Robocars via Twitter
Apr 16
DIY Drones via Twitter
RT @chr1sa: After more than a year of only virtual races, @DIYRobocars returns to the newly renovated @circuitlaunch on May 22 for the resu…
Apr 11
More…