I have been building a plane for months now and I set it up using apm2.4 the one with on board compass but I disconnected it and set it up using external. I had all the ailerons rudder motor ellervon using a Futaba receiver but didn't have much movement in the servos. I think it needed some end point adjusting. Anyway I decided I would use my EzUHF LRS with 4channel lite receiver because I planned on using it for longer flights and missions using my 3dr-radio set. I also want to connect the minim osd so I got a harnes to split the telemetry for using both osd and 914mhz radio. Here's where the trouble started. First I had an APM connected without power module using jp1 jumper and Bec from motor ESC. It worked well but the GPS had issues and I had to buy many GPS compass modules trying to problem solve the issue. I had the telemetry radio connected but when I tried connecting the harness it stopped working. I changed over to EzUHF and bought a frsky Sbus-cppm converter because I read although Sbus was implemented on APM people had reported signal issues and a frsky converter was recommended. I could not get frsky converter to work so I tried without and it worked. I used recommended firmware updates on all devices including the EzUHF and implemented MUXED setting for Sbus single connection. I calibrated ESC, and still had twitching servo's. I played around with endpoints until I could successfully arm but I also needed the power module to give current sensor info. So after removing jp1 jumper I attached the power module. It would not power the board but power was passing through it because the receiver was working. In the end I gave up and tried the APM 2.6 this is where things went strangely wrong. I had trouble installing firmware, OK, tried a couple times got it. Then after spending hours setting it all up with radio/calibrations/endpoints etc it reverted to default settings again. I have to add that at some point I did try to use the 3dr-radio & minim osd but after having no connection I gave up on using that util it was flying. Now I finally got the settings to hold firmware good, calibrations successful radio set right RTH Failsafes etc good. But I plug into servo's and now seemed OK. I took it outside to arm and try running the motor, I ran arming process and started it began throttle up, suddenly throttle jammed at around quarter and took off jammed against the fence and magic smoke started pouring out of the brand new brushless motor. So I replaced the motor and ESC with a nice new turnigy 70amp dlux and turnigy 1050kv motor. Ever since I have only been able to get either the motor working alone or servo's alone, never all of them together. I then retried the other APM and its bricked. I don't know what to do but before I spend more cash on another FC from 3dr I'm going to want to know if there's something I'm doing wrong here. I have been using APM gear for a couple years now and can get the mini APM 3.1 and mini APM pro's (I have a couple now) working fine on quads but my planes just don't want to play nice with 3dr or APM 2..s. I have quite an investment in them now with a second plane which also had issues which has now gone to fixed wing hell after not cooperating at a moment when I needed it to not crash....take off! If anyone sees this post please help me chose the right gear and info to set it up with my EzUHF.Thanks

You need to be a member of diydrones to add comments!

Join diydrones

Replies are closed for this discussion.

Replies

  • Moderator

    Just follow Martins advice one piece of kit at a time. 

  • Hi Michael,

    That's a shed load of hardware you've got there.

    My suggestion would be for you to start simple then add your upgraded hardware a piece at a time so you can identify when a problem is arising.

    Start of with just your basic futaba receiver and set up the plane so that it flies well.

    Then get your basic telemetry set up so you can monitor the plane in the air using your ground control station,  don't try the harness splitter and minim for now.

    Then add your hardware one system at a time, for example add the ppm sum converter and ezuhf lr system and see if you can get this to work, after that you can introduce your minim osd etc.

    Just now you've got too much going on to be able to troubleshoot the hardware issues you are experiencing.

This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Jan 12
gotham liked gotham's profile
Dec 3, 2020
More…