Hi All,
I am flying Fixed wing and Multirotor for aerial mapping. i have no experience in aeromodel before, just interested to use UAV technology. I was learn about UAV since a year ago from my friends who interest too with UAV, friends from local club, and of course here, in diydrone.
Yesterday, i am flying my FX-79 for testing new camera and then Something wrong happened when i switch to loiter and auto. My plane swooping downward, i tried to leveling my plane by switch to FBWA, it's working well and recovering my plane to level. After that i tried to switch to Auto then my plane swooping downward again sharper and so fast. I switch to Manual to recover but it make 'shock brake' and my battery detached from the connector and the plane fall down to grass land. luckily there is no parts broken.
I wondering if you guys could notice something wrong with my plane.


2015-01-14 17-22-24.tlog

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Actually i don't know exactly where was the problem. After that day, i found the yellow wire from GPS receiver detached from the connector (Not sure this the problem), just soldering back to the connector and reflashing apm with the latest version of arduplane, load the same parameters from that day and the problem gone!

    I tried 33km mapping mission and the plane flying quite good. the plane relatively didn't loss altitudes when turning, but still need more tuning.

  • That's not very helpful for others wanting to learn. What was the solution?
    • Erlangga, How you solve the problem?

      I had the same problem on my second maiden flight when switching from "RTL" to "Auto" on my FX79 but did not recover. I have not assessed the damage... min...$400.00.

      First flight went well about 5 days before. The only thing I did this time was not "write" a new mission. I used the existing mission. I usually always "write" a new mission, but not this time. I did "read" the mission and all looked all OK.

  • Solved!

This reply was deleted.