Help me diagnose why my outputs don't work properly:(

At this point I'd appreciate anyone's help, I am all out of ideas. I tried a new APM (2.5.2 board) but I can't get my gimbal (or any other device for that matter) to receive correct PWM signal. The board seems to be producing a 50% PWM (~1500) signal to any outputs I enable in gimbal options, but completely ignoring my MNT_RC_IN settings.

3691109257?profile=original

Gimbal Settings

3691109085?profile=original

RC IN working but RC OUT just doesn't care...

3691109148?profile=original

Here's the gimbal UI confirming this...

I've used this feature before so I know it works, but doesn't want to on this particular APM. Could it be a hardware issue ? I tried :

- PPM encoder flashed to latest

- Flashed to latest FW

- erase and reset through CLI

- re-calibrated radio

- set gimbal settings

But I got exactly the same behavior.

Am I missing something or is this APM is toast ?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Got it working by erasing/reseting again and setting gimbal option in Mission Planner instead of APM Planner.

This reply was deleted.

Activity

DIY Robocars via Twitter
Sep 9
DIY Robocars via Twitter
RT @chr1sa: We've got another virtual @DIYRobocars race tomorrow at 9:00am PT. Two dozen autonomous cars will compete, four at a time. Ther…
Sep 4
DIY Robocars via Twitter
Sep 1
DIY Robocars via Twitter
Aug 31
DIY Robocars via Twitter
Aug 31
DIY Robocars via Twitter
RT @ExplorerRobocar: Sometimes, I am really a big kid!! Having fun with my virtual RC car on the @diyrobocars track 😜😉, by using the « AR R…
Aug 24
DIY Robocars via Twitter
RT @grepLeigh: @donkey_car @unity3d @TensorFlow ~1050 episodes into training, my agent learned to erratically drive in the left lane. 🤖😆 ht…
Aug 24
DIY Robocars via Twitter
RT @EclipseCyclone: Sweet! http://Robotec.ai high performance #ROS 2 @unity3d #CycloneDDS bridge for @AutowareFdn @SVLSimulator now…
Aug 24
DIY Robocars via Twitter
RT @a1k0n: My car had a lot of trouble getting around the track at the last @diyrobocars event -- only one actual finished lap during the r…
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map https://t.co/VzykOkUt2G
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: Made a lot progress on Warm Spring Raceways track. Almost finished one lap. https://t.co/nUVpufZQyP
Aug 24
DIY Robocars via Twitter
RT @AntonioRobotics: Super fun time seeing these autonomous cars race at @circuitlaunch for the @diyrobocars quarterly meet up! The demolit…
Aug 15
DIY Robocars via Twitter
RT @a1k0n: I thought my dumb localization code was still working at the new @circuitlaunch track, but it was just *barely* working. I shoul…
Aug 14
DIY Robocars via Twitter
RT @DAVGtech: Recording of entire in person @diyrobocars race today @circuitlaunch. Fast forward a couple hours to go straight to the racin…
Aug 14
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map. Very noisy Lidar signal https://t.co/bAbeVUMi10
Aug 14
DIY Robocars via Twitter
RT @SmallpixelCar: Today’s race with @a1k0n at @diyrobocars We both decided jumping over the wall was the way to break the 11s lap time. Th…
Aug 14
More…