Help - Mini APM 3.1 250 quad motors won't spin up after arming, I've cleared eeprom via Arduino and reinstalled Arducopter 3.2.1

First post here so please bear with me, I could really use some help in this...

Equipment:
Emax 1804s (or 6s, not sure)
Emax 20amp esc’s, Simon K
Mini APM 3.1 (APM 2.6 but actually still had the compass attached…I cut the jumper trace)
Spektrum DX8, Lemon 6ch receiver
Latest Mission Planner

Problem:
My new Mini APM 3.1 250 quad motors won't spin up after arming, they sort of rough idle, and one motor spins up EVENTUALLY when i move the throttle to high. Outside of that, the motors do not respond to throttle movements.

The machine, which I just finished with new APM Mini 3.1 bought from Ebay, was flying okay but I had problems with Alt Hold where the quad would yo yo up and down hunting on Alt Hold. The think that got me monkeying with a flying setup was related to Alt Hold…every time I lowered the P factor trying to clear up the yo yo, the number I set for P became my new upper limit in Mission Planner. In other words, I couldn’t put Altitude Hold P number back up to the default of 1.000 . Trying to resolve this, I cleared the Mini APM’s eeprom via the Arduino IDE and reinstalled Arducopter 3.2.1 via Mission Planner.

After re-installation, I ran the Mission Planner wizard (and subsequently manually set the quad up on other troubleshooting attempts) and everything looked fine but I could not get the motors to spin past a ragged idle except for one motor which would eventually spin up, sounding rather rough, and would seem to respond to attitude changes on the quad.

What I’ve done to try to troubleshoot/fix:
1. Cleared eeprom and reinstalled APM several times, sometimes going back to previous version of APM to see if that would work to fix the problem.
2. Always re-calibrated transmitter.
3. Always re-calibrated the ESCs.
4. Checked to see if know problem exists where Throttle Max is set to 80 vs 1000 as some builders have noted.
5. Switched out batteries in case one was too low voltage.
6. Scoured the web for a solution.
7. Reviewed the Parameters and PIDs to see if there was something I’m missing. (Not sure I’d recognize a problem here though.)
8. Ensured that failsafe(s) weren’t set to try to eliminate their influence.
9. Always set up flight modes: stabilize, alt hold and loiter (mainly out of habit, will try no modes later tonight when I’m at it again).
10. Made myself a stiff drink and contemplated the time I’ve wasted troubleshooting issues like this on numerous multirotor builds (to include: KK2, Flip32+, CC3D, Crius AIOP, APM 2.5).
11. Went to bed way too late in frustration and despair.

What concerns me:
1. This setup flew reasonably well before I reset the eeprom and re-installed APM.
2. On the flying setup, the fact I couldn’t go above the last figure I set in the Altitude Hold P setting.
3. The fact I don’t see anything on the internet about resetting the board using the “eeprom clear” sketch that is part of the Arduino library of example sketches in the Arduino IDE.

Q: Is this ill advised? I’d think all I was doing was “clearing the decks” for a fresh APM install in doing that.

4. The fact that no matter what I do, I ALWAYS get the same result, the motors give a ragged idle no matter the stick position, with only one motor eventually spinning up, albeit sounding dodgy.
5. These clones are truly crap and I’ve over invested in them (I have another APM Mini that continues to fly okay). (For the record, I don’t really believe they’re crap. I get the sense they’re all made in by a handful of sources in Asia and the bigger names get their boards from the same or similar sources)
What I’m hoping for:
1. Someone, with much more insight that me (not at all hard to imagine) to tell me that I’ve missed some simple setting that will fix this.
2. That resetting the eeprom via Arduino is okay.
3. That someone knows great troubleshooting methods/tools to point me in the right direction (I’ve never downloaded or enabled logging, but I’m open to that… I can learn).
4. A miracle.

Any help would be greatly appreciated.

Please let me know what other information I can provide.


Thanks,

Eric

Views: 800

Reply to This

Replies to This Discussion

When I have really strange things start happening I, like you, assume corrupted memory and clear the eeprom. But I do it by installing 3.1.5 firmware. Then getting into the terminal mode and doing an erase, reset.

Then reinstall the newer firmware.

I did install earlier but didn't think to do so to get erase, install functionality. Only did it to see if fallback would help. Hopefully erasing eeprom via Arduino didn't break something. Thanks.

This really sounds like you haven't properly calibrated the ESCS to your TX endpoints.

To test, I'd use a servo tester such as any of these Here and hook it up to each ESC/Motor and then hook it up to all 4 at once.

Take your props OFF!

This will eliminate any TX and FC issues and let you test the ESC and motors by themselves. If you do this and find there are no ESC init and motor spool issues then you know that it is either a throttle endpoint or FC esc calibration issue.

Make sure your TX is set to 1000 [low] and 2000 [high] on the throttle and then turn on your TX and set the throttle to 100% with no power to your APM. Power up the APM and wait for the blue/red flashing and then disconnect the power to the APM [leaving the TX throttle to 100%] Now plug back in your APM and wait for the motors to beep once and lower the throttle to 0 and all the motors should do their normal startup sounds. Now if you raise and lower your throttle the motors should all 4 start spinning at roughly the same time and speed as you raise and lower your throttle.

I have seen so many times where people did not get a proper ESC calibration and had the exact same issue you are seeing

Somewhat my concern as well. I've removed all the ground and power leads to my ESCs so I've had to calibrate using the FC pass through where it calibrates all ESCs at once (at least I think that's my only option, I'm not an expert on that subject). I might try doing the calibration as above with your setup tips incorporated but disconnecting 3 of the 4 ESCs in turn to get them calibrated individually.

I've been suspicious of the ESCs because I never quite get the tones I'm expecting...which I've always written off to differences between the various models/brands. I do get a musical tone, not an initial short beep, and then an initialization sequence/motor spin which has made me assume I'm calibrated. All my mucking about with the sticks and calibrations also has made me wonder if I've not accidentally reprogrammed the ESCs.

When you say make sure my transmitter is set to 1000 and 2000 do you mean judge that through Mission Planner where i can see what the throttle travel throw adjustments are yielding or is there area in transmitters where I can say low stick = 1000 and high stick = 2000? I suspect you mean the former but I'm not with the transmitter at the moment to confirm.

Thanks for your suggestions on this. I'll to make sure I post how this comes out.

The 1000/2000 is done with the menus on your transmitter. As I hate Spektrum I'm afraid I can not walk you through that part, but you REALLY need to do the ESC calibration the way I described it. The reason is you need to be able to set the TX and FC and ESCs to all talk to each other properly else nothing will work right.

The ESC calibration is one of the most important initial ones you can do and until that is done well nothing else will matter.

Since I do not know which ESCs you are using I also can't be much help as they all are a tad different.

Problem solved. I had mucked up my ESC programming while calibrating them via the transmitter. Resetting their setting fixed it. Thanks Craig, you got me thinking about the ESCs. Now I need to fix the alt hold problem.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service