Help with random yaw drift

All,

Lately I've been having a problem with random yaw in my hex where it wasn't before.

Two problems. First, it always wants to yaw 10-15 degrees at take-off, but I don't think it's a crooked arm/motor as it doesn't always yaw the same direction. In fact, the direction it yaws appears to be a function of the direction it's facing; if I'm facing north or east it wants to yaw clockwise; if I'm facing south or west it wants to yaw counterclockwise.

Second, there's mild yaw drift in flight. Again, the direction is not always the same, sometimes it yaws counter-clockwise and sometimes it yaws clockwise. In this case, the direction doesn't seem to be a function of direction the copter is facing, but the yaw is more likely to occur when I'm rolling or pitching the copter rather than just hovering. 

I've tried updating the declination of the magnetometer, but that doesn't seem to solve the problem.

I've been flying the copter with this problem for 20-30 minutes a day for 3-4 days now, so I don't think it's a calibration issue. 

Any suggestions for what else might be causing the problem or what I might try to fix it?

Thanks!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Thanks for the suggestions. I re-installed 2.055, cleared eeprom, and re-setup the copter. I also switched power for APM from ESC to a dedicated UBEC, just in case. That seemed to do the trick - yaw drift is gone now.

    My guess is that the compass offsets were wacky; I've seen some mention of that problem in other threads.

    However, I do want to switch back to the APM power via ESC to see if that might have been responsible. If I find that the yaw drift comes back, I'll be sure to report it as another reason to power APM through a dedicated source, rather than ESC.

  • Developer

    Same here yestarday, i solved when disable and re-enable the mag.
    Sometime i've cyclic and costant slow rotation of the compass (i noticed this behavior in the planner) and the drone was still on the table.
    Now i thinks there's another little bug somewhere... :P

  • Are you sure the Mag is working?

    A good method to test this is to power up the board facing different directions and connect to the planner to see what is the direction is pointing. 

    If it is working, try to disable and re-enable the mag. You could have bad offsets. It happened to me yesterday, the quad was constantly yawing left or right based on my first input. After resetting everything was fine again.

    Emile

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Jetsonhacks: And I helped with the course! JetBot, JetBot, happy little JetBot! JetBot ... GO! Meet the Jetson Specialists Inspiring a…
20 hours ago
DIY Robocars via Twitter
RT @a1k0n: Designed RPi + camera mounts + new bumper for the new car. Fits great on the car first try, except my longest camera cable doesn…
20 hours ago
gotham liked gotham's profile
yesterday
DIY Robocars via Twitter
RT @RoboticMasters: Monaco GP Circuit in the Donkey Sim (coming soon). Including buildings, tunnel and all! https://github.com/robotics-masters/sim-donkeycar-f1/tree/f1-tracks @diyr…
Wednesday
DIY Robocars via Twitter
RT @breadcentric: Here are the details of #AWSDeepRacer finals: https://blog.deepracing.io/2020/12/01/aws-deepracer-league-finals-2020-round-1-schedule/ #awsreinvent2020 #AWSreInvent https://t.co/ovqsjp8V…
Wednesday
DIY Robocars via Twitter
RT @breadcentric: #AWSDeepRacer League #awsreinvent2020 Open race is on Dec 1st - Dec 31st in three categories, 15 DeepRacer Evo (with LIDA…
Wednesday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars It's just something that's easy to track with chroma keying. I ended up using different colors on th…
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Nov 23
DIY Robocars via Twitter
Nov 23
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
More…