So, Ive recently put APM on an RC Timer F800. The first few flights went very well. At the time, I was running a Futaba 8J. By the end of the first day, stabilize was spot on and the Hex was flying really well. On the second day of flight testing, I went out to try out Loiter. Stabilize was working great, but loiter would sent it into a hard bank and/or pitch from which I would recover. I decided to look at Magfield and saw that it was way above the recommended values. I moved the GPS onto a mast which now provides 250-300 in magfiled. My problem then started with the stabilize mode. When i went out to retest the loiter, while in stabilize, my hex would randomly pitch and/or roll violently nearly causing a crash each time and subsequently caused a few hard landings with minimal damage to the landing skids. After this happened, I looked at the logs only to find that it appeared as if I was commanding these actions when in fact I was not. I associated this with a bad reciever/transmiter (Futaba8J) and replaced them with a FlySky transmitter and reciever. I took the hex up for a test flight in stabilize and there was no hint of the problem existing any more. Since this transmitter was not mine, I had to give it back and replaced it with a Turnigy receiver/transmitter.  Upon going back out today, I now have the problem once more, however after reviewing the logs, there is no PWM spike like there was the last time this problem occurred.

     The motors are 4114 350kv RC Timer motors on a 40 ESC running simon K firmware (stock from RC Timer). I am running the X configuration Hex, version 3.1.5. AUW of the Hex is 20 lbs. running 6S 16000 mAh battery packs.  I have attached the log files from today and the param file that has not changed since the first day of flights. Please help.


2014-07-27 21-28-22 is the log for which stabilize was tuned and worked great.

2014-08-07 19-38-40.tlog

2014-07-27 21-28-22.tlog

Hard Pitch Params.xlsx

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Problem solved!!!  The problem lies within the design of the S800/F800. Because the arms are detachable, the connectors in which the pins on the arm contact the plate are soldered into the center plate. Those that have flown the S800 know that the arms flex considerably before takeoff. This flexing is generating stress on the solder joints on the center board and ripping the brass connectors from their solder joint. In turn, the arm flexes then the connection is lost when it reaches a certain point, but is regained when it ceases to flex. I found this after replacing just about everything on the hex and still having the same problem. I re soldered the connector and failed to go through and re solder ALL of the joints on the board which resulted in a catastrophic crash from a separate motor stopping in flight.  I highly recommend going through and re soldering EVERY pin in the board before flying this hex. I am replacing this with a Tarot 810 frame to eliminate additional failure points.

  • The pitch is always in the same direction. When I did the ground test it would start to decrease speed and sputter then stop for a split second and then start back to normal speed. This would repeat every 20 seconds or so. There is a log file attached to the original post, but I will attach the one from the ground test when I get back home. The pwm out for that motor never changed during the shut down. These esc's are not programable though. (DJI S800)

  • Developer

    Have you check if you have desync problems with motors and esc?
    The "pitch problem" is always in the same direction?
    Have you a flashlog of this issue?

  • Hello Jamie, My hex was doing the same (violent pitch forward without user input), so I moved my APM to my 100% working quadcopter. And since the Quad has been playing up as well. I moved the KK over to the hex, and the problem has gone away. I am sad to say that it is an APM thing. I noticed that my board voltage was hovering around 4.4-4.6v, so it could be my problem. I have since applied an adjustable reg and attached it to the current sensor module that I have (it used to be powered off a BEC from an ESC).

    I have tried 100s of different fixes, like new compass (not that its used in stabilise), changing the APM to different craft, erasing APM entirely, PID tuning, different motors, rebalancing props, vibration isolation, countless gyro/mag calibrations, updating to APM 3.2....

    I now have a APM 2.8 on its way from china, hopefully this fixes my APM woes. Maybe I have a bad gyro, since I had a dead 3.3v reg early in the peace that I fixed by replacing the reg. I will report back here once I have it solved.

    P.S. I currently have a jDrones APM 2.5.2 for which I paid good money. So far not happy.

    P.S.S you can see in the log that it is out of tune (overshoots and whatnot), but I have had it dialled in, and it does the same thing. You can see that it pitches by itself. It looks and feels like a mechanical problem. But the KK board flies perfectly. With the APM it is a struggle to keep it level.

  • So, I did some ground testing today and found that after several seconds of the hex being powered up just below takeoff thrust, the front right motor would slowly begin to sputter  to the point of shutting off for a split second and then starting back up to normal speed. This is a repetitive process. My assumption is that the timing is off on that particular ESC, however currently, I cannot locate any documentation on changing the timing of the ESC. It is the (Red) S800/S1000 ESC 40A SimonK Firmware ( Currently, I am trying to get RC Timer to send a replacement, however, I am still curious to know if anyone knows how to adjust the timing on these ESCs, or if there are any other considerations that I may have missed that would cause this. I monitored the PWM output to this particular motor and it never shifted from the original setting, so I think it's safe to say it is not the APM acting up.

  • 3701802650?profile=originalHere is a screen shot of the pitch on the first log

  • so, I just changed out the rx/tx back to the borrowed one and this time, I am still having the pitch issue. It was not as violent this time, however I only allowed it to do it once and then landed immediately. Here is the log file with the Fly Sky

    2014-08-07 21-36-11.tlog
This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21