Hi all,

I know that this is a very recurrent question and I apologise for any redundancy.

I assembled recently a Tarot T960 frame, T-Motor MT3514 400 (X6), T-Motor ESC 40a (X6), emax 6 axis power board, Pixhawk, 3DR GPS module(X2), 3DR telemetry radio, RC Taranis X9E and receiver X6R.

I managed to get it airborne during first trial, but unfortunately, one of my props was not tight enough and came off in the middle of a flight. The hexa landed with the arm missing the prop, which obviously broke. It also inutilise one of the land gear arms.

After getting the spares and assembly the hexa again, it doesn't want to fly. Instead, it flips as the video shows.

Any ideas on what could be wrong?

Yes, props are all spinning correctly, motors seem to have the same speed, no weird noises, frame set to X shape, etc.

https://drive.google.com/file/d/0B_iZNL5M2cKIU2dxN0FqMHNZZ28/view?u...

Views: 3440

Reply to This

Replies to This Discussion

Double check prop installation and motor spin directions
Maybe recalibrate ESC's
re set "level"
make sure motors/props are level.
If you unplugged your ESC's when you were rebuilding it, double check each motor is plugged in to the correct servo output channel on the pixhawk.

I doubt this is the issue w/ your tall landing gear, and because it used to work... but maybe trying taking off quickly..  My small/short copters almost always flip if I take off slowly from grass or rough ground, due to turbulence and ground effect.  If I 'punch it' and have them jump up off the ground, everything is fine.

have a motor kill switch programmed and easy to access if you do this with that big copter :).

Obviously ESC timing sync problem 

or unbalanced airframe, or ESC power distribution problems.

On idling, propellers don't spin at the same RPM,

what is clearly seen from your video (strobo effect).

Not sure have been ESCs are pretested ( Drone Certified) and preselected by a manufacturer to match RPM within full RPM range to a 1 RPM.

If not you get different RPM spins on idling

and different RPM spins on taking off, making your Hexa to flip.

Ok, within few days I am ready to test RPM of individual propeller with strobo

and test all Hexa propellers at the same time to discover RPM irregularities, if any.

Ask ESC manufacturer if all your ESC can read Pixhawk clock heartbeat to sync

before taking off.

I am afraid, you should be given an opportunity to buy preselected set of 6 + 2 spare ESCs for your copter, the same for motors and propellers.

Try to fix your drone to the ground and apply safe RPM range to propellers, to keep them spin at higher RPM but still not ready to take off

and use strobo to study individual RPM irregularities, if any.

(email me directly to not give trolls a chance to spam your thread)

Open Technology Park

Open Fabrication Lab

Peer To Drone Crash Investigators

manta103g@gmail.com

Arnoldo, I highly recommend that you do not reply to Darius Jack or email him, as he is a notorious troll with little practical experience with our system.

The apparent spin rate of the props in the video (visible due to aliasing) does not look bad to me.  From practical experience, I know that the "apparent" rate at which they spin is never consistent with each other when using the autopilot.  This is because even sitting on the ground getting ready to take off, the autopilot does not feed each ESC the same throttle.  There is nothing wring with your ESCs, do not attempt to return them.  Darius is some kind of professional product inspector, so he thinks every problem is a manufacturing defect.

In practice, buying identical ESCs will get you identical RPM given the same throttle (remember though, the autopilot is not giving them exactly identical throttle.)  "Drone Certified" is a made up term by Darius.  Plus, T-Motor is a trusted quality brand for motors and ESCs.  No ESCs on the market read Pixhawk heartbeat, because this is nonsensical and unnecessary

Also, Darius is uninformed about what ESC timing sync problems are.  A search for ESC sync issues turns up that it has to do with incompatibility between a motor and ESC/ESC settings.  As Darius posted in another thread: "Due to microsec delays , phase shift between ESCs, 1-2 motors get more thrust/ lift force  microsecs earlier than the other motors, making drone structure to flip due to motoric instability."  This is nonsense.  Large props do not react fast enough for microseconds to count, and even if they did the autpilot deals with variances in thrust all the time.

The airframe is balanced and the only "ESC power distribution problem" possible is for an ESC to not be plugged in correctly, meaning it wouldn't turn the motor.

Now, for my actual advice.  Scott W already said some good stuff.  Please post your flight log.  From that, we will be able to determine if the autopilot commanded the vehicle to flip (software error), or if the vehicle flipped despite the autopilot's best intentions (hardware error).  This is one of the most fundamental requirements for troubleshooting.

Examples of hardware errors include: ESCs not wired to the correct ports on the pixhawk, motor spin direction backwards, prop on upsidedown/backwards, excessive vibrations, ESCs not calibrated properly.

How to fix: describe to us exactly which wire in which port of the Pixhawk goes to which ESC.  Trace the wires carefully.  Send us pictures of the props installed to make sure they are all on correctly.  Do a motor test in Mission Planner to check motor direction.  And ask for help properly calibrating your ESCs.

As for software problems... we'll cross that bridge if we come to it.  There are others more qualified than me to troubleshoot that.

Here is a video of the motor test. I am confused as to whether they should have the same order as the one in the pixhawk. They don' have any correlation whatsoever with the pixhawk.

https://www.dropbox.com/s/puetsic9i5htpzh/VID_20160322_234554.mp4?dl=0

Stephen is right.

If ESC ports on Pixhawk are mixed and no fixed thrust can be assigned to all ESC on take off, it means Pixhawk processes sensors' output data from the very beginning on take off.

So any roll, pitch detected gets increased not corrected.

I would like to implement, Pixhawk ESC ports correct matching diagnostic tool, since

learning mode is not supported.

Pointing  smartphone's camera from top downwards to have all propellers in the field of view and let pixhawk to switch every motor individually on and have image processing software to detect which propeller is active, sending layout feedback to Pixhawk.

No need, there is a simple solution already implemented.

http://copter.ardupilot.com/wiki/connect-escs-and-motors/#checking_...

When testing the motors in order, they spin starting with the motor at the 12 o'clock position (motor A), and goes through each subsequent motor in a clockwise direction.

Arnoldo, I think your ESCs may be plugged into the wrong ports.  Lets call your motors 1 o'clock, 3 o'clock, 5 o'clock, 7 o'clock, 9 o'clock, and 11 o'clock.  That corresponds to A B C D E and F in Mission Planner.  When performing the motor test, they should go in order starting with 1 o'clock and going all the way around each motor to 11 o'clock.  Please trace the ESC wires and tell me which port number corresponds with which o'clock number.

Hi Stephen,

Thank you for the time and effort. It is very weird, the motors and esc are wired according to this diagram

Attachments:

Regarding your motor spin test video it looks you put the esc into the pixhawk not in the correct ports. I assume you clicked down from A to F down. So it should run the motors clockwise round your frame. Like Stephen said, 1 o'clock starting. 

Could you provide a video with the hex in flight configuration performing motor test from A to F? Even i have a Tarot Folding Frame myself i get the arms in folded configuration sometimes wrong. 

What i did to get the ESCs plugged in correctly: Took all out the Pixhawk and plugged them according to the motor test and the graphics you got in. Started with a random esc, plugged it in and watched which motor spins. Than i took it in the correct port of the Pixhawk. And that i've done with all of the ESCs. For me it was fool-proof because i can check for spinning direction and the correct port in my pixhawk

edit: 

even it looks all correctly alligned you could check the board orientation in full parameter list. That was something i got wrong one time after reset. Parameter ist AHRS_ORIENTATION. I got the yaw off by 180 degrees and that causes direct flip on takeoff. Doesn't look like this is your problem but you never know.. 

@Niels,

I would like to turn your excellent manual on how to avoid flipping

into Self Diagnostic Tool  (pre-flight diagnostics on arm).

Since IMU.Gyro is highly sensitive instrument, IMU.Gyro output can be

processed to detect variations in horizontal plane due to thrust/ lift force generated by individual motor set on ( RPM limited within safe range to avoid flip during diagnostic test).

Mission Planner can support such pre-flight Self-Diagnostic Test.

Could you tell me how to contact developer of Mission Planner to discuss

the implementation ?

Anti-Flipping Diagnostic Self-Test could be run before every take-off by default, disarming motors if failed.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service