Thanks in advance for any insight you can provide on this...

I have used both Xplane 10 and Fligh Gear in the past with no problems and yesterday I decided I wanted to practice PID tuning in the sim instead of with one of my planes. I uninstalled flight gear a couple months ago to free up some HD space so I only have Xplane 10 currently.

This time, the behavior was strange in that the plane in the sim was flopping around and impossible to control so I updated Xplane, rebooted, re-read all instructions and connected in order as I should. 

Suddenly the input from my RC Tx/Rx disappeared. In the set up window all the inputs are blank. No green bars or PPM values. I re-installed firmware and tried again and the froze on initializing. reset, repeated, same thing. It would just hang there indefinitely.

So, I re-installed the normal Arduplane firmware (v2.72) and everything looked fine. My Tx/Rx values reappeared and everything functions as it should, inputs, outputs, switching flight modes, etc.

I re-installed the HIL firmware again (I even tried several earlier versions) and this time it made it thorugh initializing but still no Tx input showing up.

Please help!

Thanks,

B

Views: 220

Reply to This

Replies to This Discussion

Hi Brenden,

I have experienced the loss of Tx inputs many times in the past.  The problem has been reproduced by someone on the development forum, so I'm hopeful we'll get a resolution.  Hang in there...

Paul

Hi Paul,
Thanks for responding. I found that others are addressing this issue in a Discussion On arduplane firmware v2.72. I am following that discussion because I was testing v2.72 & 2.73 beta(now 2.74beta but it seems to have a lot of comments regarding the same issues I raised here. I decided to just go out and fly the real deal and skip the sim. But I like to test in sim first, especially for autopilot tuning peurposes.
Thanks again!
Brenden

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service