Distributor

Hi

I have a plane which has the ability to perform a deep stall landing.

Due to this the elevator can be deflected quite far, which will initiate the deep stall.

I am trying to limit the servo travel for the Pixhawk - as the deep stall should only be initiated by the pilot - but not by the flight controller during normal flight.

I thought that the parameter pitch INT_MAX (PTCH2SRV_IMAX) controls how far the controller is allowed to deflect the elevator - but if I change this parameter nothing happens (same like before)

Even if I enter a value of 1 (which according to my understanding should result in hardly any motion at all).

Thanks a lot for any help

Felix

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I am also having this problems.

    If you search RC1, RC2, RC3 etc.  (in full parameter list)

    You can find servo limits for example

    RC1_MAX , RC1_MIN , RC1_TRIM .

    These did work for me on RC5 for setting up my flap servos.

    However they did not work for Elev, Rudder and Ailerons . I think they are supposed but maybe a bug on my system..

    I am using Pixhawk 3.4 with latest Mission Planner,with a Bix3 (not flown yet, with the pixhawk)

    Maybe see if they work for you?

    I really do need some help on this also if anyone knows, as I'm not able to alter the linkages any further as the servo ends are glued in place.

    Also the trim on the rudder servo doesn't seem to have an effect.

    I can set this stuff on the transmitter but I thought the idea was to have it set on the FC so that it can make the correct calculations even if a signal failsafe is triggered.

    thanks

    • Developer

      A log file would be very helpful if you could post one so we can see your setup.

      The RC#_ parameters reflect what your transmitter sends out as the autopilot needs to know how far you have pushed a stick.  In other words if you push a stick half way across or up the transmitter could be sending out anywhere between 1650 and 1800.  You know its half way but the autopilot doesn't.  By setting the min, max and trim values the auto pilot knows that when it sees a 1700 pwm signal that means its 40% of that channel.  Make sense?

      So if for example you set RC1_MAX to 1750 but your transmitter output 2000 at max that last 250pwm would be ignored as from an autopilot point of view you were at max at 1750.

      Now, the theory is that if you autotune your plane ardupilot will "learn" that you have a large elevator surface and will adjust its settings accordingly so it shouldn't deflect as far.  Your trying to limit something you don't have to as the autopilot will figure it out.

      The tuning pages are at the link below.  If it is deflecting the surfaces too much and the pitch is too large you should adjust PTCH2SRV_P.  If your still having issues you might want to look at the PTCH2SRV_IMAX parameter but you will need to be careful.  Its ALWAYS better to have 2 people tuning a plane. 

      http://plane.ardupilot.com/wiki/roll-pitch-controller-tuning/

      Thanks, Grant.

      • Distributor

        ok - this worked - thanks a lot :-)

        here's what I did (maybe it helps somebody else):

        - plane in manual mode, I used the "servo travel adjust" function of the remote control to limit my servo travel (in my case elevator) until the max and min values were ok (the elevator could not be deflected up more than a certain amount - as a full deflection upwards would initiate with this model a deep stall landing)

        - I used the "RC calibration" to teach the Pixhawk those values

        - afterwards I created a mix on my remote control to output (by the flick of a switch) values higher than the max and min values I taught (for elevator) the Pixhawk

        => in normal operation (MANUAL, FBWA, FBWB, CRUISE, etc.) the max and min deflection of the elevator is limited, thereby the Pixhawk and pilot are not able to initiate (falsely) a deep stall

        => in MANUAL the pilot can override the elevator channel and send a max value which is far higher than the max value the Pixhawk can send to the servos, thereby deep stall is initiated

        • Hi,

          This was a light bulb moment for me and I have done alot of searching. Here is my interpretation.

          There is a significant difference in radio calibration between copter and plane. In copter the objective is to get the values of full radio pwm limits from the sticks with 100% weights.

          In Plane you are after the pwm limits of the control surfaces and the trim/neutral flight pwm setting as programmed for the model set at maximum rates. (Which will not induce a deep stall or anything else outside the flight envelope)

          If you read the wiki is does actually say this in a very obtuse way. "Verify that the transmitter is bound to the receiver (the receiver displays a solid green light) and that it is set to use the correct model for your vehicle"

          In my plane (500W 800mm Sbach) full deflection/neutral for aileron is 1381-1510-1588 and elevator 1356-1538-1631. Because the deflection is so small then deadband also needs to tightened up. I tried autotune with radio calibration at full sticks pwm, before I could blink it rolled inverted then dived to knife edge below tree line away from me at terminal velocity. I got back to manual and caught it, most entertaining for the crew at least :) (I also have a compass/horizon issue)

          Can someone confirm my interpretation is correct, can we request an update to the WIKI ?

          • Moderator

            for the controller to have any hope of working successfully on your aircraft your physical setup needs adjustment, the 1381-1510 -1588 is too small for good control. this equates to full left to full right only using 207 steps and they are not equal in each direction, 88 neut to right and 129 neut to left.

            You need to mechanically adjust the servo horns and rod length to make neutral = center (near 1500) and adjust the ratio by changing the position of the control link on each end of the servo arm and the control horn, after that is done correctly you will have full servo movement and only limited aileron movement but with a range of +/- 300-400 steps. ie. 1100-1500-1900, now you will have much better control and autotune will work correctly,  make sure your CG is also correct and repeat the same setup with the elevator. have fun, good luck

        • Developer

          That sounds great - well done.

          Thanks, Grant.

        • Did you not try RC2_MAX ?

          just curious if others are getting it to work=

          • Distributor

            the RC calibration is going to set your RCx_MAX value - I preferred it to see the movement of the elevator and teach it afterward the Pixhawk (this way I didn't have to find out the value myself)

            • yeah that was a good way to setup the values Felix, all my MIN and MAX appear to be set correctly on pixhawk.

              However if I reset the transmitter pixhawk does not respect these MAX values, even though they appear to be set correctly.

              Is this just a fault my end if is there a bug in the code?

              could you possibly see if it works for you please?

              My Trim settings don't work either, the values are set but ignored. I can hopefully get it working by adjusting the connection rod but will be more awkward to fine tune it.

              • Distributor

                David - the values should be limited in all flight modes - except of manual mode.

                why do you need to reset the transmitter after setting the values?

This reply was deleted.

Activity

DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
yesterday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
yesterday
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Friday
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Thursday
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
More…