I did my FIRST Alt-Hold Today!..

Well, I have been flying my APM 2.5 (2.9.1) board on DJI F450 quad for several weeks by now. Today, I finally tried the Alt-hold. I did try the Alt-Hold a few times before but I was always holding the copter in my hands and for some reason it always wanted to shoot straight up as soon as I engaged the alt-hold. So that's why I waited for a while so I could gain some confidence.

Today, I flew in Acro and Stabilize modes for a few minutes and then on a stable hover, I initiated the Alt-hold. The Quad did not go straight up. This is Good!.. It started maintaining the altitude but it was oscillating in the veritcal axis. It was constantly throttling up and down (like 2-3 times per second). And my throttle response was very slow.

I tried a few times and all was the same. 

I then wanted to try the Loiter mode but I couldn't understand much about it since the Loiter mode includes Alt-hold and alt-hold wasn't functioning properly.

I need to fix this Alt-hold issue. What would you suggest?

I did test the AcceZ values a few weeks ago for vibration (as Richard here recommended) and it came out okay. I do not think this is caused by vibration. 

Is there anything else I need to look at?

I am not using Sonar and I was at about 15-20 feet when I tried it...

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • What is tha value for INS_MPU6K_FILTER?

    Try to use 20 and see if ALT_HOLD is better.

This reply was deleted.