Torque 930 motors

Airboss 35A ESC's

APM2.6 controller

Futaba RX

Futaba MZ Tx my wits end...working on this for two days..... firmware loaded(APM 2.6...latest stable firmware) (several times) everything calibrated (several times) sorry... no video.. but it is on my to do list! but every time I try to arm the motors.... all I get is a rapid loud beep... and no response... troubleshot all I can think.... I have tried arming and plugging in the battery while connected to Mission Planner... and there are no errors in there and the display says its armed, but all I get is the rapid beeping.... but wait... here is the weird thing. The Airboss ESC's do not calibrate like others...they do it automatically

but I thought I would go through the motions of the process.... so..TX stick at full... plug in.. unplug... plug in.. as predicted, the ESC's go into programming mode....... so I let the ESC's go through the process...and when it gets to the tones to Reset Factory Defaults... I pull down the throttle.... and then I get the appropriate tones from the ESC's that they are armed and the tones counting the cells in the battery... and I get throttle, etc... all motors spin, respond to throttle, etc. etc... but the lights on the APM are still blinking blue/red alternate...... and once I unplug the battery, and re-plug it in...back to square one... just the rapid beep with no response from the motors.... at a bit of a loss

any ideas?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • here is something.....  not sure if it means anything or not....

    on the flight data screen...

    on the status tab...

    I noticed that all the CH#IN status show the calibrated PWM from the radio...

    but the CH#Out for all the channels reads 1014 and doesn't change.

    Does this mean anything?

  • Mine does a rapid beep when it reaches the low battery threshold and starts RTL. Are you sure your battery is ok and that the min-voltage and mAH reserve settings is set correctly?

    Also AFAIK you don't wait for the ESC's to cycle through the tones. You wait of the first tone, then bring the throttle down, you should hear a confirmation tone, then you can up the throttle to test that they are in sync (but don't take off until you've cycled the power).


    • Thanks. Tried several different batteries.  Voltage good... made sure the battery cuttoff was low.. and tried with disabled...

      also..  I did what you mentioned as well.  First tone.. drop throttle... get confirm from ESC's and cell count beeps...

      and all 6 motors work.. respond just fine to the throttle....

      until I unplug the battery and plug back in.. then back to the beginning with the rapid beeping and no response...

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25