I'm so stuck. Can't test motors, can't arm motors.

OK.  So after a minimum of 400 hours or research and testing I'm going to go ahead and ask for help before I rip all this APM/Arudpilot/3dr radio stuff in the trash and waste more money putting in a Naza v2. 

Here is my current setup:

- Tarot 690s (all carbon fiber frame with folding arms and Legs
- Tarot 2 axis Brushless Gimbal for the GoPro Hero 3 (works awesome for professional footage)
- 6 = Tarot 2814 / 700kv Brushless motor (2 are red and 4 are black in color for orientation)
- 6 = 13inch Carbon Fiber Props
- 6 = DJI 30 amp Brushless ESC
- 3DR APM 2.6
- 3DR GPS Antenna
- 3DR Power Module
- Foldable GPS Antenna Mass
- Hexatronics Power disturbution board with all Bullet connectors used
- 2 = Century 4000mah 3s 11.1volt Batteries
- 1 = Zippy 5800mah 3s 11.1volt Battery
- Hitec X1 all in one Battery Charger (can charge both Transmitter and Copter Batteries)
- Turnigy 9XR 16 channel programmable Radio
- Century 3s 11.1volt 220mah Lipo Battery for Transmitter
- FrSky DJT Telemetry 2.4ghz Module
- FrSky V8FR-II High Voltage 8 Channel Receiver

This is my first non-Phantom build (not that you build a phantom, but upgrades, etc.).

Got it all built right. But during setup I had some issues connecting to Mission Planner. Had to go into CLI, setup>reset>factory reset.

Bam. Ok, now I can get into MP. Go through the wizard. Calibrations. Setup channel 7 for auto-tune. 

So after I'm finished setting up it. I figure I should test the motors before I put her in the air.  So I click on test motors in the GUI. All I get "command denied by ardupilot".   Hmmmmm weird. 

Ok, I go to Flight Status screen to make sure i'm not getting any Pre-Arm check errors. Nope. I arm the motors and spin them up. Then I disarm.  Hmmmm why can I arm this thing and the motors spin up but I can't test them.  Same in CLI mode. test>motor test .... "command denied by ardupilot". Keep in mind that these are Opto 30amp ESC, you cannot calibrate them. 

So that's problem #1, and I can't even find a single hit on Google when i search "command denied by ardupilot" when testing the motors so I'm apparently the only one on planet earth with this issue. 

The 2nd and probably bigger problem and possibly related to #1.  

The 2nd problem is I cannot arm  the copter once I take it outside and plug the lipo in. Take it outside, plug it in. I get a solo beep from the ESCs, then the little musical tone like I should.  On the APM board when I plug it in. The input side is working, orange tx light is flashing, GPS connector is green, GPS antenna is powered and locks onto sats.  but...BUT, the output side of the board or something is hosed up. I get nothing on the APM led indicators. The red led flashes once or twice the very first second I plug the battery in and then nothing. So I can't arm it. So it's not an "arming" issue per say, but the APM is not initializing or booting up as it should. 

To make matters more confusing. If I plug my copter in Mission Planner via the USB. APM powers up as regular and I can arm.  If I plug my LiPo (tried 3 different ones) while it's connected to my PC, then disconnect the USB, I can bring it outside and fly it. 

Possibly the PMU could be bad, but I HIGHLY doubt it. If it was a power problem, the problem would persist as soon as I unplug the machine from the USB. 

There is something going on between these Opto 30amp ESC and the APM board. It seems impossible to troubleshoot because I don't know the boot routine on the APM 2.6.  If I plug the LiPo in before the USB on the APM board and then hit connect. I get two beeps from the ESC and a timeout.  If I plug the LiPo in before the USB and connect to APM via CLI it connects fine but the ESC beep non stop. Then I run motor tests, the beeping stops but the motors never actually test.

Does anyone have any clue where to start trouble shooting on this? Any logs I could check that show what the hell is going on inside APM at such an early stage?

I'm desperate over here.  

Regards,

Brian

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Brian, does the APM has a safety switch like the PIXHAWK is having?
    If so, you may need to keep the safety switch pressed to reload the boot loader when you connect your LIPO...
    As I am flying with the. PIXHAWK, that's the way to reload a boot loader when it get's lost...
    You may give that a shot..
    I am thinking that by powdering via USB you may skip the need for a boot loader, which is why it works when you initiate from USB power, instead from plain LIPO powered device,

    Good luck...
    • I tried your suggestion, hold down safety switch when applying LiPo power. Did not work. So I tried it re-calibrate ESC all at once. Didn't work. So I tried all at once calibration, holding down safety switch with throttle up to start calibration. Didn't work. So I tried it several more times, each time holding down switch when applying LiPo power, alternating between throttle up and down. ESC never entered calibration mode. Suddenly,once when the throttle was down, it armed and all motors ran! Kept it hooked up, took it out, had my first -rc4 flight, amazing! Have not been able to get it to arm and turn props since... Many attempts to repeat - no go... Might be a race condition in the software somewhere...
  • you are not running telemetry correct?

    I have a feeling it it something in the prearm check log, I have been there before setting up arducopter. It seems deceiving however it is all I fly now, because it is so good.

    what mode is the default flight mode set too?  Lastly did you try and arm the motors prior to testing them?

    • Interesting results from last night:  

      - Load 3.1.5 (no cal, no wizard, nothing but software load...).  Apply LiPo power, all ESC's beep:  beeep-beeep-beeep - beep-beep - followed by single ongoing beep, all motors wiggle.  Arms and flies normally.

      - Load 3.2-rc4 (no cal, no wizard, nothing but software load...).  Apply LiPo power, 1 ESC beeps:  beeep-beeep-beeep - beep-beep - followed by single ongoing beep, only that motors wiggles.  Arms but only one motor turns.  Disconnect / reconnect LiPo, 4 ESC do beeep-beeep-beeep  (no double beep, no ongoing beep), but that's it...  Arms but motors will not turn.

      - Reload 3.1.5, all operations normal, flies perfectly with no cal/wizard, etc...

      How can software loads affect the ESC in this manner?

  • By any chance did you do the radio calibration/esc calibration part with the throttle trim down to the level you would use to set the failsafe pwm threshold?  If you did, then the APM will never see the normal low throttle setting as the minimum setting to arm.  It would only see the throttle slightly raised and would not allow arming from the radio.

    • My ESC cal's were done with all trims centered...  I tried Brian's suggestion: boot via USB, connect MP, plug in LiPo, disconnect MP, and try to fly it.  It armed, got one ESC to beep, only that motor would turn.  I disconnected LiPo, armed it again, got 5 ESC to beep, 5 motors turned.  Progress!  So I disconnected LiPo again, armed it, no ESC beeped. no motors would turn...  Same on-going problem, only happens with -rc3 and -rc4, -rc2 and previous fly perfectly.

      • Yeah I bet we have the same issue, whatever it is. 

        • Can someone please remind me how to get a previous beta? Lost my saved copy, I'm looking for 3.2-rc2.
          Thanks!
  • So here is what I would try, the steps have helped me in the past:

    Take the APM out of the loop and test each motor and ESC group on their own connected to the receiver and power.  Once you are sure that everything is functioning properly we can check the power.

    Are you powering the APM from one of the esc's or from the power module?  If an ESC, put a volt meter on the ESC you plan on using and test it again as above, and attach a volt meter to see if you are getting the correct power all the way through the power band.  If you are using the power module, plug all of the motor systems in and then attach a battery and a volt meter to the power module to make sure you are getting proper through the entire power band again.

    So, if everything above checks out, we will move on to checking the APM itself.

    Unplug it from everything and completely wipe it, epram and all.  Plug it into your computer, install the software rev you wish to use, calibrate,and test to ensure that you are getting valid flight data when connected over USB.  Be sure that all of the flight modes are set to stabilize and also be sure to turn off all of the prearm checks.

    Now we can plug the APM into the copter.  Be sure to move your propellers one position to the right so that if you get things spinning it will push itself into the floor rather than trying to lift off.

    Making sure that everything is wired up, turn on your controller and begin the ESC calibration steps.  You should be able to spin the motors at this point.  If this works, we can move on to testing magnetic interference on the APM.

    Run the compassmot test following the instructions in the wiki.  If you are getting too much interference, correct it and test again until it is resolved.

    At this point, if everything is working, you should be able to power up and arm your copter whether you are inside or outside.  If it still will not arm then we now need to revisit the radio calibration to ensure that we are not dealing with a reversal issue for some strange reason.  If the radio calibration checks out okay then yes, you may have a did APM.

    If your copter is now arming properly and the motors are spinning on arm, you can go back into the settings and turn the prearm checks back on to be safe.  Keep in mind that if any of the prearm checks fail for any reason,it will prevent the copter from arming.  For example, I can't get my copters to arm indoors as I can't get a GPS lock.  Also don't forget to put your propellers back on the correct motors before you try and fly.

    Hope this helps, following these steps has helped me diagnose all sorts of weird issues in the past.

    • SAFETY NOTE: Should read "Turn props upside down and move over one motor".

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…