I upgraded a stable flying APM 2.0 quad running ArduCopter 2.7.3 to 3.1.3 and introduced a wobble

Hi guys.. I wonder of any of you have any ideas on how to reduce a wobble.  I went through all the steps as I did when I built the quad and installed firmware 2.7.3.  I'm attaching my flight logs hopefully someone can give me advice.  The wobble is left right forward and back ... the wobble was around 60hz.

Attached you will find my log

Views: 488

Attachments:

Reply to This

Replies to This Discussion

Not sure if this is with yours but, when I upgraded mine I had a bad wobble also. Looking around the settings it ended up being Roll and Pitch P values of the PID increased about 50% (~0.085). I lowered the values to the previous stable values (~0.054) and the copter is fine. Hope this helps....

Thanks!  That makes sense.     I adjusted those values back when I was running 2.7.3 but I didn't have a wobble then, it was a slower wobble so it was more like a drifting circle.

I'll try it.. right now I need to rebuild my quad.     crashed.  I had a wobble but it was stable, but for some reason when the battery power went  low the fail safe cause my quad to fly away.    A tree caught it.   Now I am rebuilding it.

I'll turn  failsafe off until I know what happened.  My fail safe was RTL.

Update...the new firmware is buggy on APM 2.0.    I got tired of dealing with 3dr and switched to a multiwii pro. Cheaper.  Much cheaper.plus can run multiwii, ardupirate, and arducopter

It is very stable.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service