Should I expect a crash at some point?

Nervously I took the Spy 750 Y6 up for the first time in over 3 weeks (had a warm spell of 25F today).

In stab it flies great, then switching to poshold it seemed fine, but did the twitchy thing again for a few seconds here and there, then seemed to smooth out (subjective). I brought it down and hovered nearby where it stayed rock steady for a minute or so and landed.

So, what does it mean when INAVerr goes to 255 and stays there? From what I understand it is the FC not receiving data from the GPS properly. Apparently this copter has done it from day one since transplanting the PIxhawk and running on AC3.2 and 3.2.1, with the 3DR GPS and the current CSGShop Neo-M8N. These errors did not exist on the Y6B with 3.1.5 and the 3DR GPS.

Any help is appreciated.

Views: 2523

Reply to This

Replies to This Discussion

I tried to upload the log the first time around...I am attaching the zip file here

I tried to upload the log the first time around...the compressed file is still more than 7 MB..but for the time being here is a log from another flight..its a short flight in loiter but the INAVerr rises to 255 at round about 2 mins into the flight and stays there for the rest of the time...

Attachments:

I am completely with you in bringing this matter to the fore....when the lead copter dev says that this is a real problem then it has to be serious (ish)...I am really nervous that this may lead to a trashed copter...

It is a bit frustrating though that this issue has not attracted the attention of the wider dev community...

I don't know if my logs would help or hinder.

I have a Drotek M8N - http://www.drotek.fr/shop/en/home/512-ublox-neo-m8-gps-hmc5983-comp... - mounted on a 5" tower above my TBS Discovery.

The first flight included Circle mode, an auto mission and some general PosHold flying which after 12min still had a 0 inaverr.

The 2nd flight was pretty much the same but without the Circle mode and half the time showed a small error of 27 towards the end of the flight.

I have seen older logs with an inaverr of 255 but even with those the one constant is the quad always flies perfectly.

Attachments:

MarkM,

  That's interesting. A dedicated M8N thread was created. Copy your post over there if you wouldn't mind.

http://diydrones.com/forum/topics/gps-issues-do-i-need-a-gps-ground...

Several threads here on DIYDrones and RCGroups have been opened to discuss about the explanation and what represent these INAVERR errors in performance monitoring in logs

This problem was reported end of  January

Still no answers from 3DR/Dev guys, to tell us something about this INAVERR in logs

A ticket was opened in Github about that

I know that they are probably busy, but could be great if somebody could tell if this INAVERR error if indicating a problem or is not

I found a post from Randy who in last November was thinking INAVERR at 255 was not a "very good thing"

http://diydrones.com/xn/detail/705844:Comment:1482305

Marcus,

     Thanks for the info.  Your copter missed one GPS message and went 0.07seconds without a fresh GPS update (you can see the 400ms jump in the GPS time between lines 2593 and 2606).  You were in Loiter mode but it was so short lived it didn't upset the navigation at all.  If it was -rc6 you would have seen a very slight twitch.  If that INAVErr was 255 meaning it had maxed out the recording of errors I'd be more concerned.  For now, this is consistent with what I'm also seeing which is that we're getting occasional missed messages which we still need to get to the bottom of but in low numbers it's not dangerous.

One of my post and Randy's answer about INAVERR was deleted (I asked why) on the thread

http://diydrones.com/forum/topics/gps-issues-do-i-need-a-gps-ground...

For all of you to be aware , please read below Randy's answering  to the  INAVERR problem and my following answers

So if you agree, as this Thread opened by DG is generic to INAVERR, perhaps we could continue here

Let me know, thx

@tshado,

The Inav errors mean that inertial nav has not received a GPS update within 0.3 seconds.  So that probably means that the GPS is running too slowly (i.e 3hz or less) or messages are being missed.  I've never used one of these GPSs so I'm really not sure what exact technical issue is that's causing the missed messages.

It's hard to say how badly this will effect inertial nav's position and velocity estimates but it will have a negative effect I think.

I didn't understood that https://github.com/diydrones/ardupilot/issues/1972 was opened to to modify INAVERR counter from 8 bits top 16 bits

I will suggest to Jdennings who opened the ticket to open another one( or modify this one title) as this error is showing with 3DR LEA 6H GPS  we can get very high numbers of errors for these GPS Updates

As this INAVERR is meaning that  inertial nav has not received a GPS update within 0.3 seconds , I agree with you that the GPS could be running sometime very slowly (at 3.33 hz or less frequency)

But as Lea 6H GPS is being set at 5hz upadate , I doubt GPS will update several hundred of times at 3hz and in between recovering to normal updates

Seems more to me that code is missing from time to time GPS updates

Of course not really easy to see  degradation on EKF results and flights performance (remenber some twitching was reported by some users ), but If GPS messages are missed several hundred of times with 3DR GPS, this is bad

I think this problem should be investigated to nail why GPS updates are missed by code

Forgot to add that in the logs there were not GPS message  like "bad GPS health"  or others errors pointing to a GPS errors

I havebt digested this or INAVERR posts but as I was seeing these posts I thought I'd check the logs of mine. I don't have a particularly promlematic loiter the odd twitch.

I am running the virtual robotix Ublox neo 8 and the specs say it has 5Hz update rate, I guess even before arducopter reconfigures it. I am running a virtual robotix microbrain with 5.1 bootloader, and some of my logs show high INAVERR, some don't, some step up a couple of times, some keeping ramping up to 255 early in the log.

As I said I haven't noticed particularly poor loiter, if amything though when tuning I increased GPS weighting.

My post is for info and comparison with other peoples setups., as my setup is slightly different but has the same issue, the common things being arducopter and the ublox 8 but in slightly different forms. 

@Stuart Brookes

Thanks for posting infos,

Another guy Mlebret posted the same results on two of his multirotors,with 2 different VRBrain boards, and 2 GPS (VR and RTFQuad)

But as I mentionned to Randy , this INAVERR error reported in logs is also occuring with 3DR LEA 6H GPS

So even with 3DR GPS, logs are showing up to sevral hundred of times missed GPS updates !

I think this problem should be investigated and understood

But no news or updates from Randy or other devs...

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service