Install previous firmware

Hi all,

I'm running 2.9.1 on an APM 1 board and since updating my stock quad has not been the same. Thanks to Randy's help, we've determined that the new code doesn't play well with the older chipset. I'd like to reinstall v2.8.1 since I my quad behaved nicely with that code.

How do I do that? I've searched the boards but have been unsuccessful in finding instructions. I downloaded the firmware but getting it onto the board has been illusive. I see the "Pick previous firmware" link under the firmware page in MP but the names are cryptic. See pic.

3691001050?profile=original

Any help would be appreciated.

Thanks,

Jason

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Thanks for the replies. The one that ended up working for me was the one that started with "bb5ee0e..." Not sure why it's different from yours Thomas. Actually, I had to try a couple of others like "320cab..." and "76ff.." - they showed 2.8.1 firmware for the quad but I would get the same 404 error from the server.

    After installing 2.8.1 on my stock 3DR quad and running the radio calibration, I took it outside for a quick test. It works so much better than 2.9.1 did. More stable and responsive. Alt hold needs a bit of tuning but it's 100% better. It would be great if there were some disclaimers or system requirements that warned of possible incompatibilities when updating firmware (ie. this firmware only supports APM 2.5 or something to that effect).

    Having such great resources to constantly develop this product is pretty amazing when you think about it. But from an end user perspective it can be really frustrating to "update" to the latest and greatest promising new features or stability only to learn that your hardware isn't fully supported as with the case of APM1 and v2.9.1. I'm thankful there was an easy rollback process and folks on the board to help... though again, as an end user, some documentation would have been helpful. And what's with those cryptic strings??! Why can't it simply say 2.8.1 instead of "bb55eeblahblahblah"?

    Thanks,

    Jason

  • UPDATE: I just used the scroll wheel on my mouse over the MP screen with vrs's of APM and as you scroll the icon info changes to different versions. I will try 2.8 and see if my APM 2.5.1 passes the accel sequence.

    S

    Just tried and firware below 2.9.1 is 404 server not found. :o( almost got excited sorry. As you go through cryptic code the associated vrs appears under icons. another 2.8.1..... iloads but "accel" prompt in CLI not recognized. :o(

  • I think I have similar issues with my 6+ month ago manufactured 2.5.1 board. After update patch for 2.9.1 which MP prompted it has been acting up with accel calibration and gps data response. I would also like to try 2.8 and saw the individual tweaked versions? that seem to be those cryptic codes. I tried erase eeprom and reset and reloading and configuring over and over but nothing MP still saying nan nan nan nan ????. A bit frustrating since I only need to use stabilize but cannot get a simple imu calibration.  I am loading a post with vid,

    S

    -I fly freeflight 1.3 controllers with added baro mod and they only require 1 position imu so this is all new the acc axis process though it is totally still when clicking next/done in each position. Using my welding shop PC sorry for any typos it is dusty. :o)

  • Admin

    @Jason,

    See if you can find: 55ff88a35ed8e625088cc48981c74f3fdf7857bc. This should be ArduCopter 2.8.1.

    Hope this helps.

    Regards,

    TCIII

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…