Hi,

I asked this in the Ardupilot forum a couple of days ago, but I received no response so I'm asking here. I apologize for repeating the post.

--------------------------------------------------------------------------------------------------------------------------------------------------------

I have performed some test flights using an IRLOCK. It seems to be working ok, I've tested it in three different locations making a couple of missions in AUTO mode and the landing accuracy was around 30 cm. The only issue I have is that in almost every test, the copter starts descending, hovers at about 40 cm over the target, lands and then bounces up. After that, it lands again and the motors are disarmed.

I've checked my logs and there seem to be no issues with my sonar since it shows stable readings below 3 m (as shown in the picture below). The logs also show this bouncing when the copter is about to land.

I should also add that the vertical distance between the IRLOCK and the beacon is around 40 cm when the copter touches the ground, my only guess is that maybe they are too close when the copter lands. The log for my last three attempts is attached below. I hope you can shed some light on this issue.

Thanks in advance!

Bin file

Views: 129

Reply to This

Replies to This Discussion

Javier,

  Im somewhat new to all this, but it sounds like you need to activate ground effect compensation. It turns most of the load to the gps instead of baro while landing. The baro gets confused by the prop wash apparently.

-Jon

Reply to Discussion

RSS

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service