Is my APM 2.0 broken?

In the pursuit of a vibe free frame i have been experimenting with easy low-cost solutions, and I've come up with a cracker that i will soon share with you all once I've finished gathering data.

 

In the meantime I have a concern about my apm2.0 test board.

 

As you can see from the graphs and log below my the vibrations in hover (from a shaky frame) are being very well dampened indeed, however I am seeing some nasty spikes on the z-axis, every few seconds or so.

 

3691002726?profile=original

 

 

If i swap out for my APM 1.4 or 2.5, using same radio and everything else, there are no spikes. It's just this board.

 

Does anyone know what might be causing this? See specifically line 1491 of the log shows one of the massive spikes. My z-axis vibration is almost undetectable in the logs. I'm just a bit concerned about these massive spikes.

 

3691002765?profile=original

 

I should add it flies great....

 

2013-03-08 12-59 1.log

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Thanks guys, i can confirm its a loggin problem, possibly a hardware one.

     

    This thing is flying great but it will not produce a sensible log for love nor money.

     

    I think the SD card or something connected to it is screwed. I do an erase, do one flight, plug it in, it tells me i have 253 logs starting at -254, none of which are downloadable, the dump sort of dumps everything but makes not difference. Ive tried to reformat the SD card following the less than definitive instructions in the wiki. Can't get it to play ball.

     

    I will play some more.

     

  • Developer

    I talked to Randy about this and he seemed to think it was just a logging problem. But I am not convinced. We need to get him to have a closer look at it.

    Some observations:

    You have a bunch of errors in this log:

    ERR, 29, 0
    ERR, 80, 0
    ERR, 147, 0
    ERR, 148, 0
    ERR, 104, 0
    ERR, 142, 0
    ERR, 39, 0
    ERR, 75, 0
    ERR, 24, 0
    ERR, 52, 0
    ERR, 44, 0
    ERR, FS, 0

    You also have spikes through everything! Not just the z acceleration. The only thing you don't seem to have spikes in is the ATT (except Nav Yaw).

    And the performance measure doesn't make sense at all!

    Sorry I can't help more!

  • Any chance that your anti-vibe system is allow the board to actually move too much and occaisionally strike something below it?

    BTW, I'd love a peak at what you're doing. ;)

This reply was deleted.

Activity

DIY Robocars via Twitter
Sep 9
DIY Robocars via Twitter
RT @chr1sa: We've got another virtual @DIYRobocars race tomorrow at 9:00am PT. Two dozen autonomous cars will compete, four at a time. Ther…
Sep 4
DIY Robocars via Twitter
Sep 1
DIY Robocars via Twitter
Aug 31
DIY Robocars via Twitter
Aug 31
sam liked Jimmy Oliver's profile
Aug 25
DIY Robocars via Twitter
RT @ExplorerRobocar: Sometimes, I am really a big kid!! Having fun with my virtual RC car on the @diyrobocars track 😜😉, by using the « AR R…
Aug 24
DIY Robocars via Twitter
RT @grepLeigh: @donkey_car @unity3d @TensorFlow ~1050 episodes into training, my agent learned to erratically drive in the left lane. 🤖😆 ht…
Aug 24
DIY Robocars via Twitter
RT @EclipseCyclone: Sweet! http://Robotec.ai high performance #ROS 2 @unity3d #CycloneDDS bridge for @AutowareFdn @SVLSimulator now…
Aug 24
DIY Robocars via Twitter
RT @a1k0n: My car had a lot of trouble getting around the track at the last @diyrobocars event -- only one actual finished lap during the r…
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map https://t.co/VzykOkUt2G
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: Made a lot progress on Warm Spring Raceways track. Almost finished one lap. https://t.co/nUVpufZQyP
Aug 24
DIY Robocars via Twitter
RT @AntonioRobotics: Super fun time seeing these autonomous cars race at @circuitlaunch for the @diyrobocars quarterly meet up! The demolit…
Aug 15
DIY Robocars via Twitter
RT @a1k0n: I thought my dumb localization code was still working at the new @circuitlaunch track, but it was just *barely* working. I shoul…
Aug 14
DIY Robocars via Twitter
RT @DAVGtech: Recording of entire in person @diyrobocars race today @circuitlaunch. Fast forward a couple hours to go straight to the racin…
Aug 14
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map. Very noisy Lidar signal https://t.co/bAbeVUMi10
Aug 14
More…