Whenever I initially use the latest version of Mission Planner, I reflexively "upgrade" the APM 2.5 firmware. It's an instinct I've developed after working with computers for 30+ years to make sure everything is concurrent, and I've done this for the last 6 revs of the MP. I take it this is different than flashing an ordinary eprom, because reflashing something usually results in damage to the eprom. Besides, it would see that the firmware is up to date and wouldn't touch it... right?

I DL'd MP 1.2.52 did then 'upgraded' the firmware (which was already 2.9.1b, but y'know how reflexes are). Now it won't connect to the MP, nor will it arm the motors from the Tx. The usual blue and red LEDs aren't lit but the Tx/Rx LEDs are active. It's appearing in the device manager as "ArduinoMega"

The reset button on the APM doesn't seem to do anything...

I'd reformat the eeprom, but I can't connect to the MP...

Any ideas?

Views: 7288

Reply to This

Replies to This Discussion

You don't need to click connect when going to the Terminal page in MP. Before clicking on Terminal make sure you have the correct com port set and then click terminal. You should see 'com port open' message in the text pane.

Wait for the prompt to press three times and you should be in CLI mode where you can reset to factory settings and erase the dataflash by typing 'setup' 'reset' then 'setup' 'erase'

Thanks Bill!

...but a prompt never appears. If I were to get a prompt, what exactly do I press 3 times to get into CLI mode?

I've changed my port to 15 and the APM still won't respond. I'll repeat: the red and blue LEDs won't light up. If I plug the battery in, nothing happens except  for the startup tones and the ESCs beeping and twitching every 2 seconds.

It's acting like it's in some kind of calibration mode, but Rx won't respond to the Tx even though the Rx is lit (detecting the Tx).

I set my port back to 4 just in case.

I failed to mention the Tx/Rx LEDs by the GPS port were rapidly flashing, but I didn't mention it because I don't have a problem with the GPS. MP still times out on connect. Here's the details:

The only connection to the APM 2.5 is now the USB, The only lit LED is solid green, labeled "Alive!"on the board, right next to the Rx/Tx LEDs.

Also, the CLI is unresponsive, although the blue LED lit for a second when I selected 'Terminal' from the MP menu. Otherwise, the single solid green near the GPS port is the only light.

Any clue?

Oh, it's the power light that's on :)

I removed ALL cables from the APM. Sorry I mentioned that, didn't intend to confuse

Thanks for the help, Monroe. I've opened a ticket with 3DR tech support. Maybe they'll know what to do.

Yes Monroe, I would appreciate your help in fiddleing with this blasted contraption! Thing is, it flew several times before and didn't give me trouble until I tried installing my radio, which eventually worked out (they can see each other but can't connect to MP). I may have bushwhacked the APM in the process :\

100,000 cycles for the eeprom? There's a slight chance I may have fried my APM, but now it doesn't seem as likely. But knowing my luck...

I checked all 3 USB sockets on my computer and they all checked out.

What shall we fiddle with next?

When you plug it in do you see an entry in the Device Manger in control panel. It may have. Yellow Question mark next to it. You can launch device manager quickly by pressing the windows key and then typing device manager.

If you see the icon that relates to the APM right click and select uninstall. Then reboot you computer and unplug the APM

When it reboots, plug in the APM, stop windows from searching for the driver on windows update. It should pick up then the one installed on you machine.

Launch MP, when you select the com port drop down, you should see the APM listed if its working.

I uninstalled/reinstalled all the drivers then power cycled, but to no effect...

So, I was unplugging/plugging my APM peripherals in various combinations when THIS happened. Aren't these things supposed to be crimped onto the board?

They came right off with the same pressure I always use (which is very little). Too much rocking motion?

Also, I was looking over the LED guide: https://code.google.com/p/ardupilot-mega/wiki/LED ... and I cannot recall ever seeing the 'B' LED lit up. I've always seen blue and red, but never yellow. Except the Tx/Rx LEDs near the GPS, and those have always flickered on and off... even with my telemetry disconnected or when not connected to MP or my Spektrum? Hm...

I've had this for 4 months, so it is definitely out of any implied "warranty", but could these issues be regarded as manufacturing defects? Maybe I should request an RMA from 3DR? Or is more tinkering in order? Personally, I'd rather tinker, but the dislocated ports are a bit of a bummer :\

But to answer your question Monroe: I didn't see anything different with the LEDs than before. I have no idea what a JTAG is, but I'm eager to learn!

...And thank you to Drone Savant for the link!

Nothing's changed: solid green LED and nothing else. I'll glue those ports back on after the APM is diagnosed.

Mind you everything's still unplugged from the APM except the USB to my laptop.

To be precise: when power is applied to the APM, either through USB or lipo:

1.) The blue LED "B" will flicker for a fraction of a second then remains dark

2.) The green power LED lights up solid

3.) The startup tones are heard, followed by the number of cells in the battery (3 beeps)

4.) The motors start twitching once every two seconds and the ESCs beep, first in unison then slowly drifting out of sync with each other after a few minutes.

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service