Is there a known problem with KDE and xxxHawk?

So for something different I bought a CUAV Pixhack (the real one) for this current H4 Alien 680 build. To head off criticism, it is not a cheap Pixhawk clone. It is high quality hardware in a machined aluminum case with IMU dampening and no connectors on the top. It's quite nice. Whether the latest version will result in good vibration levels without foam remains to be seen.

Next I bought the tried and true KDE 2814XF-515 motors and decided to go with KDE 35A ESC's. After going through all the instructions, warnings, updating firmware etc., I was happy to see it arm properly. However, the joy turned to frustration when one of the motors puttered off. With a bit more throttle, the motor turned on, then a few seconds later stalls out. Rinse and repeat.

First thought: power wiring to the FC wrong, as that has been a bone of contention with KDE ESC's. However, the PM is connected along with a 5v UBEC on the power rail. It should work right?

As the affected motor was #3, I swapped with #4 and yep, now #4 does it. Bad ESC? I'm not convinced yet.

Next I tried a genuine Pixhawk. Same thing. Sigh.

I'm tempted to buy a replacement ESC but have heard others having problems with getting their KDE ESC to play nice with a Pixhawk, yet others have no issues.

My question for you KDE guys, how did you wire the power to the FC?  Here is KDE's diagram for 3DR products: http://www.kdedirect.com/blogs/news/18220995-xf-uas-esc-and-flight-controller-compatibility-list

Also, how did you set up your radio (Taranis) and any settings in MP?

Thanks.

BTW, I did not buy these ESC's from KDE; bought them from classifieds at RCG. The guy swore they were never fired. The wiring looked untouched, but you never know.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Just in case someone ends up here I'm going to copy and past my reply to you elsewhere on diydrones:

    So I have a similar setup to you. 

    KDE motors

    KDE ESCs

    Pixhawk.

    5v bec plugged into main out 8 on Pixhawk

    I also has similar issues as you and followed your little thought process/guide at the link you provided above.  Didn't quite work out for me, *BUT* I seem to have solved the issue for me. Mind you, this is bench only at the moment so who knows if problems will present themselves once airborne.  I'll detail my steps:

    Fresh install of copter 3.3 and reset all parameters to their default.  (I notice that RC_MINx & RC_MAXx all seem to be 1100-1900 by default now)

    Do mandatory setup for frame type, compass and accel calibration.

    *Radio Calibration* is where I had success.  I noticed that if I set my throttle min max in my Taranis transmitter to 1100-1900, the radio calibration screen in Mission Planner/APM Planner would show a different value. 989-2015 let's say.

    I navigated to page 7/12 'SERVOS' of the Taranis and adjusted the min-max for the throttle while looking at the radio calibration screen of Mission Planner.

    On the Taranis my throttle min is -79.6% for a value of 1132us

    my throttle max is 77.2% for a value of 1932us

    and my ppm center is 1539 delta.

    On the radio calibration page of Mission planner though, throttle min is exactly 1100, throttle max is exactly 1900, and the midpoint is exactly 1520.

    When I power up, the motors make that familiar beep every half second.  When the arm button is pressed, beeps double in speed before a confirmation tone.  Throttle down right then sees the motors spin up.

    I had no need to change any of THR_MIN, MOT_SPIN_ARMED, or THR_MID.

    This has worked flawlessly every single time since I've done it so for me, at the moment anyway, this seems to be the key to get the KDE stuff and the Pixhawk to play nice.


    Hopefully this helps someone out!

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars virtual AI race is tomorrow morn at 9:00am PT. You can watch live on Twitch https://www.meetup.com/DIYRobocars/events/275268196/
1 hour ago
DIY Robocars via Twitter
New version of Intel OpenBot! This resolves many of the issues with the first version, including a much smoother tr… https://twitter.com/i/web/status/1352395636369313798
20 hours ago
DIY Drones via Twitter
Using ArduRover with an RTK GPS https://ift.tt/2N9I3RO
Tuesday
DIY Drones via Twitter
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
Jan 15
DIY Robocars via Twitter
Jan 15
DIY Drones via Twitter
Jan 14
DIY Robocars via Twitter
RT @Heavy02011: @diyrobocars : A Home-brew computer club* for Connected Autonomous Driving on Jan 23rd, 2021 https://www.meetup.com/Connected-Autonomous-Driving/events/275728684/ #Meetu…
Jan 14
DIY Robocars via Twitter
Jan 14
David Hori liked Isabella Domi's profile
Jan 12
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ Autonomous Driving Assembly at #rC3. join us at https://rc3.world/rc3/assembly/diyrobocars-f1tenth/ ⁦@f1tenth⁩ ⁦@DAVGtech⁩ ⁦@DWalmroth⁩…
Jan 11
DIY Robocars via Twitter
RT @chr1sa: New car designs coming for our next @DIYRobocars @donkey_car virtual race on the 23rd. Choose any one you want at race time Le…
Jan 11
DIY Robocars via Twitter
RT @RoboticMasters: Thanks to @EllerbachMaxime and the Sydney Uni Capstone Students the @donkey_car @diyrobocars simulator is getting a ma…
Jan 11
DIY Robocars via Twitter
Jan 6
DIY Robocars via Twitter
Dec 28, 2020
More…