Folks:

10 seconds after powering the APM, the right motor starts jittering.

When I test this same motor without APM, it works fine. That cancels out bad bullets, bad ESC or bad motor. I have tried a different ESC on this same output and the jittering is still there.

I have soldered all the pins myself, checked them and re-soldered them. I'm pretty good with soldering.

I have re-uploaded the firmware (quad 2.3), erased EEPROM, re-calibrated the radio, but the jittering doesn't stop.

It's a brand new ardupilot mega 1280 board, not a 2560.

Mission Planner is 1.1.34

motors: jdrones 850kv

ESC: jdrones 20A

Thanks in advance!! :)

Views: 847

Reply to This

Replies to This Discussion

I think you may be able to narrow down whether it's the APM, ESC or Motor by swapping the wires around.  For example disconnect the right motor's esc from the APm, and instead plug in the left motor's esc.  Does the left engine now jitter?  If "yes" then it's the APM.  If "no" then it's the ESC or motor.

Next try swapping the right motor's ESC with another motor's esc...still jitter?  If Yes then it's the motor, if "no" it's the ESC.

Thanks for your help Randy!

I swaped the wires and a different motor jittered. I tried an ESC that doesn't jitter on that output and it jitters. It's the board.

The APM has a 1280 chip, not a 2560. Is it still compatible with the latest firmware of Quad and Mission Planner?

How do i fix a board?............

There's not much difference between the 1280 and 2560 except for the code space.  I'd be a bit surprised if it was a code issue..much more likely to be a soldering issue.  I suppose it could be a defective board although I've never heard of this problem before.  I think  you'd better make a short video and post it here and/or just contact jDrones and see if they'll send you a replacement.

I will make a video of it. It's a sad show.
I bought the board from a local electronics store, not from jdrones. Cheaper, but no refunds.

Have you ever heard of an AttoPilot 90A/50V Sensor complicating things? It all started after installing that sensor on the battery line.

The sensor comment would have been a handy piece of information up front - narrows down the search considerably.

The obvious response is, disconnect the Attopilot Sensor and see if the jitter goes away.  First step would be to leave it inline with the battery but disconnect the I, V and Gnd lines at the APM.  If that fixes the jitter, it may have introduced an earth loop producing noise. Try reconnecting just I & V and see if you get sensible readings and no jitter.

If that lot doesn't solve the jitter, remove the whole thing and we'll need to think up a Plan B!

Hi Dave, thanks for helping out.
I did try without the Attopilot sensor and the jitter was still there, but something tells me the board was already ruined by then. In fact, I think there is something wrong in the manual, in the section about 'Measuring your battery voltage and current consumption with APM'

It says:

Solder the cable to the pins shown below on the APM 1 IMU shield. The black wire should go to the GND pin, and the red wire (or the one furthest from the ground) should go to the pin next to it, which is marked AN0.

In a 3 cell battery, that is 11.1 volts which is a lot of voltage. I know it's going through the 3.9k resistor, but I feel not a lot of people have tried this connection out. It'd be good to know if it's working for somebody else.

Additionally, these instructions have changed. It use to take 3 to 4 resistors depending on the amount of cell on your battery, now there is only one.

Do you have any means to measuring voltage through telemetry on your quad?

thanks again!

I'm just about to set up my voltage monitoring.

I've just updated this reply as I overlooked something.

Initially, I thought that applying the 11.1V battery voltage to the IMU without the other resistor would fry the MCU input.  However, after examining the MCU datasheet, I see that it has proection diodes on all inputs which, together with the 10K resistor already in series with the battery voltage, should limit any overload current to well within safe margins.

If you have the 3.9K resistor installed, there should be no problem as the MCU input voltage will be well within its ratings.

So, if it's not an Earth Loop, I can't see why your Attopilot sensor has upset the APM.

I had a 3.9k resistor installed... It will remain a mystery i guess. I bought a new Ardupilot Mega and I'm flying again.

Maybe the resistor was shorted, so the board was getting all the voltage.

All I know is that this time around I will install all the resistors and all the cells wires, as it was working fine like that before.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service