Jittery orientation after upgrading 2.8.1 to 2.9.1

Sorry if the answer is buried in the monster 2.9 release thread (there's no search within a thread function here is there?).

After upgrading from 2.8.1 to 2.9.1 my quad now reports a very jittery artificial horizon when connected to the Mission Planner (video capture from MP attached).

This is with the quad sitting on a stable, level surface, no battery plugged in, just a USB connection to the laptop. I did a CLI reset and accelerometer calibration.

Anyone else experiencing this?

2013-02-11 20-55-04.avi

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Andrew,

    See this video posted by Randy Mackay on youtube:

    Jittery HUD on 2.9.x

    Best regards,

    Jan Willem

  • I think from this video it is something to do with not having a great GPS fix indoors 

    https://www.youtube.com/watch?v=SXppOmZ3Rpg

    Video from Randy Mackay

    hope it helps

  • exactly what I was going to post this morning.

    Something very similar. Just upgraded to 2.9.1 and I find that the vertical speed indication is fluctuating +/- 0.3m/s and the indicated height +/- 1,5m. This is with the quad on the bench connected in the same way as your self. This is on an APM 1.4.

    So I went back to 2.8.1 and all is stable again.I have good vibration levels for 2.9 apparently. (They are within limits)

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
More…