Joystick control of ArduPlane not working

Hi Guys,

I was trying to setup a Logitech Attack3 joystick for manual control of my APM running the latest ArduPlane 2.4 firmware.

I'd like to mention that I have NO R/C system connected to the APM (I don't even own one). Perhaps this is the problem. If it is so, I think you guys might be able to provide me with a solution with the below problem.

I opened Mission Planner after attaching the joystick and opened the joystick panel. After setting it up, all the axes worked perfectly. I had previously calibrated the joystick in Windows.

But, when I connect to the APM via through Xbee @ 57600 baud, the joystick control stops working. The values in the panel revert and freeze. No joystick inputs are taken. APM status tab shows all the R/C override channels to be permanently set at 1500 PWM. Tried via USB and same problem.

One important thing here, the buttons keep working even after connecting, probebly because they are not overriding the R/C channels.

I have to close and reopen Mission Planner to get joystick functions back, but only till the APM is not connected.

Please HELP!!


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • No if you connect to the APM by any way, then go to the Config/Tuning tab the Full Parameter List and scroll down till you find which parameter you want to change. You can also search by a search text box somewhere in the right column. After you change any parameter it will turn green. If you want to save your parameter press write parameters which will save the parameters on your APM

  • How important is commenting out the trim_radio() part of the code? I have over 50 successful flights on both fixed wings and multirotors using joystick control. (no R/C on board at all). I have set the Min, Max and Center to the right numbers, and the center (trim) does not change after reboot. What would make the center (trim) value change during flight anyways?

    • Hello, 

      I'm trying to use the joystick but it still doesn't work. Have you done any modification to the code to make it work?


  • Good day, I have Genius joystick connected to Mission Planner 1.3.7, every thing is working as I expect. But when I connect the Ardupilot 3.1.0 via the MAV link, the joystick not responding anymore. To recover the joystick I need to restart the Mission Planner.

    I also recompiled the Apdupilot, commented out the trim_radio() in system.pde and added the definitions at the top of this file like

    # define RC1_MIN = 1000  

    # define RC1_MAX = 2000


    and so on for first 4 channels. But this gives nothing so I am not sure I am doing the right way the modification of sources. Could you guys give me some clues? Many thanks! 

    P.S. I am not sure how, but one time I have done the Radio Calibration with the Joystick, but now I cant open the Radio Calibration without connecting the Ardupilot to Mission Planner, so joystck becomes anavalible everytime.  

  • expo is off (0) for each one and actually grayed out for throttle.

  • hello! Am having a weird problem, i have connected a logitech attack 3 joystick to my system, i intend to only use the joystick system and eliminate the radio for the time (testing), i have assigned the axes to the required channels also, problem is :

    if i pull my joystick (elevator : X axis), I get a pitch up in the plane

    but when i push my joystick down (elevator : X axis), I do not get any pitch down, nothing happens!!

    infact the green bar on the Joystick menu does not move to register the 'Down' Movement!!

    I need help! iam not a programmer so ill be very grateful if somebody could explain the solution to me.



This reply was deleted.


Santiago Perez liked Santiago Perez's profile