Just can't get them to work, Please help

Since I received the telemetry unit I can't get them to connect no matter what I try from all the forum posts. 

When I try to connect with the APM Planner software ver. 1.191 or 3DR Radio config util. I get the following:

Using the Connection Mavlink button in the top right with proper com port (6 for tx or 8 for rx) and 57600 baud always fails giving "No Heartbeat Packets Received'. When I load the Tx or Rx(with FTDI cable) I have identical values because I have updated the firmware for each.
3690938217?profile=originalWith both Tx and Rx connected to PC(Win7 x64) I get (.5 second) blinking green lights.

If I connect Tx to PC and Rx to my model(APM2) the Tx has blinking green light (solid for about 3seconds and then two one second blinks)  and Rx has blinking green on with bright fast blinking red light.

I have APM2 with 3DR 915Mhz telemetry.


Pic of FTDI connection:

3690938121?profile=originalPics of connection to APM2:

3690938191?profile=original3690938230?profile=original

Can anyone suggest some next steps? Thank you.

remote config Sik 1.5 HM-TRP.jpg

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I just got a 3dr radio 915

    Its communicates  while connected with the FTDI meaning solid green led/

    But no communication on wireless meaning flash green led.

    Does any body know whats the problem?

    Thanks

    • I have a CLUE for those who are still searching for answers. My telemetry worked just fine when I had everything set up together - in this case APM + power module + minimOSD + VTX + camera. Then I took things apart while waiting for a UBEC to arrive for powering the VTX end of the OSD separately, so I had the OSD cabled to the APM telemetry port and via that harness to the telemetry air radio. The telemetry would not link i.e. green blinking lights on both radios + a red blinking light on the air radio. I went through the whole reconfiguration via FTDI, but while doing that realized that the radios did link when they were both connected to my PC. It had to be something with my wiring on the quad. So I unplugged the connection to the minimOSD leaving only the straight connection between the APM telemetry and the air radio - then they linked up just fine. So, apparently connecting to the one end of the minimOSD while it is not also connected to the VTX & camera prevents a linkup. As I said; it's a clue for anyone searching for answers.

  • I had a problem in the last 2 days also. We have a balloon launch in a few days and we really needed to get this fixed.

    (yes...it is fixed)

    Our problem turned out to be (as usual) a dumb stupid mistake. We have a Sparkfun data logger on the same port. Used to work great. On the data logger someone unplugged the APM2 TX data line from the data logger's RX input line and put the APM2's TX line on ground ! Needless to say, when you ground the 3DR radio's TX line, things don't work so well !

    So in our case, putting the data loggers and APM2's tx to rx made it work just fine again.

    Hope you guys track our APM2 going up to 100,000 feet for the 4th time !

    Look on the website http://APRS.fi looking for callsign KE5VSH-1 at 16:00 UTC on Monday 7/2/12 !!

    Earl

  • Hi Steve,

    I have the same radios as yours. Based on your pictures above, I can see some wrong connections namely:

    1. For the "air" module attached to the APM2, if you look at the reverse side of the board you will see the pin config. The ground is the left most part of the board. So based on your photo above, you must reverse the cable facing you now with the black cable(nearest the red cable) connected to the ground pin (which is nearest the edge). You must look closer at the back of the module with a magnifier and enough light to see the pin configurations and properly connect the cable to the APM2.

    2. Your FTDI cable is also reversed. The ground side of the radio is nearest the edge of the board.

    Sorry for the delay in responding to this thread. Looks like everything is okay now with your radios and you were able to sort the wiring correctly.

    Serg

  • Moderator

    What are you using to power the APM2 when trying to communicate? You will read voltage on your servo rail, even if you don't have the power to drive your radio and servos. Be sure you are using a power supply capable of delivering enough amps... a 3S lipo, or I use a ham radio power supply. 

  • Looks like this is a tough one!  Seems like the uC and coms are working.  Settings all seem right.  I can't see any obvious electrical problems with the board.  But they just won't link.

    Without some RF test equipment it might be hard to do much more diagnosing.  Seems to me the only part left would be the radio side of the chip, the PA, and the oscillator/crystal.  If you have a multimeter with a frequency counter or an oscilloscope you could check the oscillator.

    I would try reflashing the firmware on both radios.  Other than that I don't really know enough about the chip radio to do anything more without a SiLabs debug adapter or more test equipment.  You might just have to send them back.

    Try doing all the other AT commands and post the results.  Maybe something will stand out.  I can run them on my set also for comparison.

  • Moderator

    Just out of interest Steve, have you tried just clicking on the terminal button in mission planner? does it connect then, and print out loads of symbals?

  • You need to do some more testing before giving up.  

    When you connect them to your PC what are you getting from the com port?  When you hit +++ is it going to AT command mode?  What commands have you tried?  Read out all the settings on both modems and compare them.

    Have they ever worked or did a setting change / firmware update screw them up?  Since you updated the firmware I'm assuming they worked at some point?

    You need to make sure all the settings are the same on each radio.  Don't trust the MP or config tool.  Verify everything manually on each modem, don't trust the remote AT commands.

  • Moderator
    Please post a close up photo of the cable between the radio and APM and (if 400mhz) the ftdi-radio connection. Thank you.
This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…