KK Multicopter

Hi, I've made a Quad X copter using KK Multicopter blue board v4.5 (ofcourse I waited for 15 days to receive the board after placing the order). But mine is not going up. Its rotating on the ground. I don't what the problem is.... I've tried and tweaked as much as I can do by referring many sites. Also build 4 frames. But in vain. Its been two weeks I'm trying to make it fly.I've used1450kv outrunner brushless motors12A BEC Esc3S 25C 2500mAh 11.1v battery(Above all Powerhd company)kk multicopter blue board v4.5Futaba 6 channel T6EXA TxFutaba 7 Channel Rx at 72 MhzEverything seems to be fine. The board is getting armed and all the controls are working fine.The weight is under 900g.Trying to figure out what happened since 1 week.You can check this videohttps://www.youtube.com/watch?v=CQiBCYOLdk4I'll be more than happy if some one could help me on this ASAP.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I think the earlier frame which I used and shown in the video is small (12in / 305mm) since the props size is 10x4.7 and there could be TURBULENCE building between the props causing the entire vehicle to imbalance and out of control. So I rebuild another X frame with arm length of 350mm(overnight) and tried to minimize errors fixing errors and vibrations. This seems to be working except minor errors with gyros and the gain adjustment. ( you can check the video). This needs to be rectified and stable flight needs to be achieved.
    All suggestions are welcome.
This reply was deleted.