Hello all. 

I've connected a Lightware SF10/c to my pixhawk serial 4/5 port as the instructions here show:http://copter.ardupilot.com/wiki/com...re-sf10-lidar/

My SonarRange is flat on 0. I can see that the unit is powered up because I can see the dot on the floor with a digital camera. I've triple checked continuity of the cable I made and I also (using the cable I made for the Pixhawk) with small jumpers stuck in the little connector, attached it to a USB to Serial adapter and with Putty I can see the distance just fine.

I dropped it down to 9600 baud, still nothing.

I'm new to pixhawk/apm world so I'm not really sure how to troubleshoot. I've double checked the wiring.

I currently am running firmware 3.3.2.

Lastly, this is still not done being built. This is my first experience with a Pixhawk. I'm upgrading from an Eagle Tree Vector. I'm not done rewiring. I am still waiting for a power module because I refuse to use the little 90A one that was supplied by 3DR. 

Thank you all.

Note (may be TMI): My parts list is as follows

  • Tarot FY680 Iron Man
  • Sigma Summit Motor Mounts (~740mm now)
  • PixHawk Controller
  • Mauch 4-14S 200A Power Module (pending delivery)
  • Quanum MT 3510 630KV
  • Turnigy K-Force 30A (Opto)
  • Zippy Flightmax 8Ah 6S 30C or Venom 6s 12Ah 30C
  • 13x5.5 Carbon Props
  • 3DR uBlox GPS/Compass
  • PX4FLOW Optical Flow Sensor
  • Lightware SF10-C LIDAR Altimeter 0-100m
  • Turnigy 9XR Pro
  • Floureon 915MHz Telemetry
  • 2W 1.3GHz NTSC Video Transmitter
  • HawkEye DTF-UHF 1w 16ch

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

            • Hi Jeff,

              Yes, the 0x55 address would be 85 for the RNGFND_ADDR in Mission Planner.

              I've been looking into the issue of connecting LightWare devices with I2C to various versions of ArduCopter, I'll let you know anything I find out.

              • Well it looks like my wires and device are good, at the end of my I2C lead, I'm showing 3.2V on the green and white leads and 5V on the red lead when powered via USB, and it looks like a signal is being produced on the green and white leads.

          • All sorted from my side,

             Just a question, where is the sonar range saved in the log file. Would like to geo ref images with height above ground in addition to baromatetrix/GPS altitude.

             Thanks

            • The sonar is in the CTUN (Control Tuning) packet with the SAlt (9th parameter) tag.

    • Go with I2C if you have spare ports. Supported in 3.3.3rc2 and firmware release will probably be within a few weeks.

  • We have an SF10/C connected to our pixhawk using serial 4. We tried custom firmware provided by lightware, 3.3.2 and 3.3.3rc2 but all of them result in the quad failing to hold altitude. It drifts down faster and faster, until the throttle is lifted up and after a delay it gains altitude again.

    We have a test drone with a lidar-lite on the Iris+ and this works great. The response time from waving your hand under the lidar lite to getting a decreased reading is less than a second. However waving a hand under the Lightware SF10/c takes 2-3 seconds to record the change. Could this lag be the cause of the problem?

    Setting serial 4 to Mavlink bypasses the SF10/c and the quad uses the barometric altimeter and holds it height as normal.

    Anyone else seen this behaviour before?

    • @Justin

       Have you done more testing in ALT Hold

       Flew today in gusty conditions ( and although the copter is not well tuned yet) it did hold altitude better in STAB mode than in ALT_HOLD

       Thanks

    • @Justin - have you checked the settings in the SF10/C itself? It comes with some filtering options and these may be turned on - they can increase the response time. Also, there are some smoothing/response parameters in the setup of the AC software, including things like throttle response rate.

      • The filter was indeed set to on. We have switched it off. Testing will take a while since our quad crashed for reasons unrelated to the laser alt and will be returned to the manufacturer for testing. Could be 2-3 weeks before we can test the SF10/C on the new quad.

        Are any of the "smoothing/response parameters" in the pixhawk firmware related to the SF10/c? As I mentioned, flight performance is normal when the SF10C was disconnected.

        The extended kalman filter would do some filtering on the laser altimeter, Do you think there are some arducopter parameters to change/look-at that will affect the responsiveness of the SF10/C?

  • @Mathew: Please could you try again with the software version attached and see if that solves the problem. I've checked it out with my SF10/C and it works fine.

    copter-3.3.2-lightware-v2.px4

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23
DIY Robocars via Twitter
Oct 23
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
Oct 18
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13
More…