After each flight i try to download the log file from my APM unit. Sometime it generates a log file, but most of the time it reports that there are no logs to download. Im taking off and landing manually & flying around waypoints autonomously. When i do get a log, its only a small part of the flight. Iv turned on all log-able fields in the terminal.


Im trying to understand when the log files are wiped. I assume that its when the APM unit loses power? APM gets reset each time i switch between CLI & flight mode, but thats unavoidable. The unit has battery power the entire time.


It seems like short flights are more likely to get logged. I was starting to wonder if my logs were exceeding some max size because of all the fields i turned on. I dont think this is the case because the logs that i have retrieved are small (>1mb). Also KMZ files are not being generated automatically, iv been manually generating them with the "recreate KML" button in the log download dialogue. Iv attached a log from a flight earlier today (this was the only log generated, it was dramatically shorter that the other 2 flights i flew before and after). oct%2011%20short%20flight%20%28manual%29.log


I would appreciate any help. Im trying to output some data for my engineering project.



Views: 523

Reply to This

Replies to This Discussion

Just adding my name to this so I get an update.
I've often wondered this myself, but usually just use the APM Planner Logs.

the log you posted uses the entire dataflash

Dumping Log number 1,    start page 2,   end page 4096


4096 is the last page in the dataflash, so it would appear your using the entire dataflash for these short logs.

ie 4096 * 512 = 2 mb

try testing on the ground, just start in fly mode, and log for say 2 mins. then try downloading it to see how much it uses

To the left of the "Add Rely" button, and the bottom of the first post there is a "Follow" URL that will keep you updated on the thread discussion w/o needing to add a post, if you like. 

Hmm thats interesting. I figured that since the log was under 1mb it wasnt a space issue. It could indeed be that im running out of "pages"


Iv tried turning off everything except for the essentials: ATTITUDE_MED, GPS, MODE, CMD.


I have the APM unit sitting on my desk by the window connected to my pc. The GPS has locked on and the flight data is streaming into the APM Planner and displaying my location correctly. I left it sitting there for 10 minutes. Then i switched to CLI mode and opened the Terminal tab, then pushed the log download button. This is what i get:


Init ArduPilotMega 2.2.1

Free RAM: 2106

load_all took 6192us

using 2520 bytes of memory

Compass initialisation failed!

Entering interactive setup mode..

If using the Arduino Serial Monitor, ensure Line Ending is set to Carriage Return.Type 'help' to list commands, 'exit' to leave a submenu.Visit the 'setup' menu for first-time configuration.

Move the slide switch and reset to FLY.

ArduPilotMega] logs


No logs available for download

log] logs



: ( Looks like im still not getting any logs. Any other insights?


Thanks alot for your help!

Iv just tried logging for another 10 minutes. Still no log file being created, the same result as most of my flights. Since its connected to APM Planner through USB, i tried logging data through my PC. That worked fine, it created a tlog which i used to create a KML. The KML looks perfect.


Unfortunately i cant use that method when im flying cause i dont have telemetry..

try doing a log > erase from the cli. and then the log

Yep tried that 10 minutes ago, and iv just produced a valid log . Im hoping thats fixed it! Maybe it rewrite over the old log. Weird.


Im testing it again now. It was successfully creating a small log occasionally before so it could be just a false positive. Fingers crossed its working properly now!


Now all i need is for the rain to stop so i can go and produce some real data!

Just completed the second log. It looks like its working properly now! I tried turning on NTUN this time too. Woohoo!


Thanks for ur help! Ill post on here again once i get some real data.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service