Long GPS Fix Time (Ublox LEA6)

So i recently purchased the ublox LEA6 gps from 3DR, I am having a really tough time getting a GPS lock. I have it hooked up to a battery and esc, sitting outside with an unobstructed view of the sky. It's been over an hour and still no lock. I live in IL so coverage shouldn't be a problem. Are there any trouble shooting steps I should/could take?

(full disclosure: I was able to get a lock a couple of times last week, but none this week.)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Yes, I returned the GPS to 3DR and the replacement solved the issue

  • Same problem. but sometimes it works perfect fixing 7/8 sats in 10 seconds. i think is a soldering problem.

    Edit : now i am sure the problem is bad soldering of the ufl cable under the ceramic patch antenna. now i try to resold.

  • Received my replacement GPS from 3DR today. Haven't tested it yet, but with a cursory inspection I see that the solder joints connecting the ublox chip seem to be of better quality(on my old one, some of them seemed to be missing/incomplete) . I'll check GPS lock tonight and report back...

  • Same problem :/

  • I have RMA'd my unit to 3DR, so we'll see what happens

  • I have exactly the same problem.  Luckily I ordered two APM2.5 kits with these GPSs.  I unpacked the other GPS, plugged it in and it got lock nearly instantly!

    So, I'm guessing the other one is bad/dead.  Not sure if I did anything to kill it - plugged it into the APM just like I did with the one that is now working....

  • So what have you changed from last week to this week (hint, hint)?

    I have it hooked up to a battery and esc

    Likely, it's a power problem with noise coming from your regulator (BEC or ESC). Eliminate the noise and willing to bet it locks just fine. Most likely, some component last week wasn't connected and this week, it's making bad EMI/RFI.

    To block noise, use an inductor in series on the power wire feeding the entire APM.

    I posted a pretty clear answer with link to usage of the filter circuit in this thread http://diydrones.com/forum/topics/new-3dr-ublox-gps-causes-interfer... 

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13, 2022
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13, 2022
More…