Since updating Mission Planner (Windows) to 1.3.2 and 1.3.3 I and a number of my associates have not been able to complete Mag calibration. 

The new dialogue box appears when selecting Calibrate, and it rotates in sympathy with the APM 2.5/6. But no matter for how long you work it the calibrate routine does not complete.

If you abort the Calibrate routine and check the APM2.5/6 against a real compass the two tally. APM 2.5/6 is correctly indicating the points of the compass.

This issue has only arisen since 1.3.2 onwards.

You need to be a member of diydrones to add comments!

Join diydrones

Replies are closed for this discussion.


  • I have had a better upperbody work out today than I've had in a few years twirling and dancing with a 15 lb quad! 3000+ points and an almost solid sphere, really!

    Is anyone working on this or should we all go back to 1.30?

  • I've installed previous version 1.3 and all ok.

  • Over 7,000 data points and no joy.  I stopped when my arms gave out twirling a hex!  tlog attached

    Parmele-2014-05-24 15-20-20.tlog

  • Admin


    I am using MP 1.3.3 and I just tried calibrating the external compass on my Pixhawk equipped rover using the telemetry radio and no matter how many times I go around each axes, after I hit the "done" button I get a message that says "not enough data points".

    Also the rotating display data points have gone from just single pixels to small blocks.


    TCIII ArduRover2 Developer

  • ... all day i was thinking that i killed my two APM boards :)

    same thing on APM 2.5.2 amd 2.6.

  • Yes.... I have the same problem with my pixhawk v2 and mission planner 1.3.3 after update from 1.2.2. From apmPlanner2 works fine.

  • Your not alone.  I'm having the same exact problem with 1.3.2 .... I had almost 5 thousand data points and finally gave up.

    • This issue is now being tracked with the developer in GitHub here -->

      • Another with the same issue. Tried firmware erase and reload, as well as the beta copy for mission planner that is available with in the app itself. +3000 data points for me with no luck.
        To get flying, Uninstalled mission planner and loaded the APM Planner, mag calibrated perfectly.
        The domain name '' is parked at Register.TO Domain Registrar
  • Developer

    can you please post a tlog. so I can see why its failing

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21