Minimosd Black screen of doom

So i bought a minimosd direct from 3dr.  First time ive done this.  I wired it up to be powered off of the flight controller (pixhawk) and just have video and ground running through the video side like i always have.  No video is coming out.  Even when i power it via the ftdi.  If i drop one of my off brand minims into the harness everything is fine.  

What are the chances I got a bad one?  Is there something inherently different to the 3dr minim over something from RTFquads or hextronic?  I also flashed the firmware and charset to minimosd extra copter 2.4

Any help would be appreciated.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I think your mistaking terig for me. I have both pads soldered. This isnt my first rodeo with the minim. I have four other aircraft with it. I dropped an 11 dollar rtf quads minim on it and i have no issues getting osd data. The 3DR one just gives me black screen. Ive tried all different firmwares and charsets. Nothing works.
    • http://witespyquad.gostorego.com/flight-controllers.html

      All his pixhawk/apm stuff is top notch. I have real apms/ pixhawks and pauls knock offs. Theyre just fine. He even fixed the 5v reg bad gyro issue on the apms.
      • Great to know!

        Do the ship from the USA? 

    • You're right, sorry about that. The RTF quads are an excellent value and I have a few. In fact the only Minim I had that just died for no good reason was my first 3DR one. At $50 a pop, I care, but not at $11, with no apparent functional difference.

      • Tom where are they 11? I have found 18

  • Their is something funny here with the board... I am using 12 v on the fpv side and 5v on the board side...

    So it was black screen then no over lay it will load a hex but only can get it to do it sometimes. Worked fine now just weird... Not sure what is up with these as mine work fine after alloy of fussing with it and when I went to use it with the same fpv system on another quad nothing... Now I just have it and I cannot get it to boot on the screen


    Either no over laybor black screen not sure if it is the beta osd extra firmware 2.4 or what


    It was working hell I have video of me flying with it bit now not so much
    • In your initial post you said you wired it to be powered off the Pixhawk, now you're saying you're feeding it 12 volts on the analog side?

      Beyond a "possible" noise reduction by giving the analog side it's own power supply, I fail to see the worth of doing two separate power feeds. When a Minim gets fed 12 volts the first thing it does is pass it through a regulator and drop it to 5 volts. 

      That said, Minims can be a bit temperamental at times. Try reflashing, updating both the hex and character set and verify your SR parameters are correct. And if you are using the RC version of 3.2, there have been some Minim issues reported with that.

      • the only way that I have it working in the past was feed the 12v fpv side with video and ground then on the other side coming from the telemetry port or serial port whihc I though was 5v...

        I fixed my issued from the adrucopter 3.1.5 but the minim just stopped working..

        not sure where I said it was powered all from the pixhawk...

  • Did you remember to solder the two jumpers together (front and back)  on the new board to power it off the Pixhawk? If so, are you certain the video and ground connections aren't reversed (that's the one I make all the time)?

  • weird, mine worked fine the last time I hooked it up..l I even psted a solution, I just pulled it an put it on a another quad... nothing, so I connected the fdti cable nothing...

    now I do not think it can be gone.. as it work the last time I flew a few days ago had not problem and use minimosd extra the 2.4 beta.. now I am miffed... 

    anyone?

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
More…