I have two MinimOSD boards purchased from 3DR that no longer talk to ArduOSD (failed to talk to bootlogger issue). While I found links to fix this issue, it is no help if each time I plug it into Pixhawk it works once then bricks again. 

Below is summary of wiring and what happened:

I soldered the two areas on the board to feed 5v from Pixhawk Telem 1 through the whole board.

Wiring - I have Fatshark TX wired to video out  and ground on MinimOSD and fatshark camera wired to video in and ground on MinimOSD. I have the 5v from the Fatshark TX going to the Fatshark camera. 

When I plugged the MinimOSD into PC with FTDI cable all was fine and set it up and upgraded firmware and chararcter set no worries.  Then I plugged into Pixhawk and turned on. Everything worked and gave myself pat on the back. Then I powered down Pixhawk. When I powered it up again the OSD and camera feed were gone completely. When i plugged the MinimOSD back to PC it no longer talked to bootlogger.

I tried again with another MinimOSD and exactly the same thing happened.

I have ordered a USBasp to add bootlogger back on cards but how do I stop it doing this again and again?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Update

    I got the usbasp cable. I looked at videos on how to upload bootloader and it seemed to work. I then managed to get the hex file for ArduOSD to upload. But here is where my success ended. As soon as I click the done box for the upload it somehow deletes the bootloader and I can no longer talk to the minimosd anymore. I have literally spent all day trying to get this thing to work and nothing I have found on the internet has worked.  Any help would be greatly appreciated. Please HELP

    • Not a lot of talk out there on this thread but in case you are wondering what has happened I have been talking with 3DR and sent them my wiring setup and they are sending me new minimOSDs.  Hopefully these ones will be all good.

This reply was deleted.