minimOSD no mavlink data. SR3 missing?

Hi new to DIY drones and ardupilot.

Im wondering if anyone else has had the same trouble as me or can direct me toward a suitable resource to help me out.

It goes like this:

Ive loaded up the latest version of arduplane to my apm2.6

ive flashed my minimosd with minimosd extra

ive connected the two (no telemetry radio)

all i get displaying from the OSD is No Mav Data.

after researching this i found that i have to set SR0 and SR3 parameters which can be found in the full parameter list.

i can find all the SR0 parameters but the SR3 is missing and seems to be replaced by SR1. so now i dont know what to set. i've tried treating SR1 as SR3 to no avail. i've alsoposted in the minimosd extra section with no conclusive result.

i hope this can help really looking forward to playing with arduplane. :)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I am having this issue too.  I followed all the setups steps correctly, Fyi, I have been using MultiWii for a year so I know how detailed you have be to make sure everything is right so everything works.  I have an Minim OSD loaded with MinimOSD Extra 2.4 (Plane).  I found a table with the correct SR0 and SR3 (now SR1) values and input them using advanced parameters in mission planner.  I hit "write", disconnected the USB cable and restarted my APM2.6.  I still only see "NO MAV DATA on my OSD.   Any ideas?


    • Anyone had success with this?

      I use MinimOSD with copter 3.1.4. Have done and redone the setup several times with no luck. My hud shows "No Mav Data" and then transitions to panel 1 with no updates showing.

      I use the Y splitter cable on APM 2.6 with the 433Mhz telemtry radio. Communication with mission planner is perfect with all telemetry data updating.

      • I had to revert to an older rev of firmware to get it to work. APM Plane 3.0.1 works on the plane side.

        • Interesting. Should this then be considered a regression in the newer firmware versions or does the setup work differently now.

          Would be good to have some clarity as whether this is truly "broken" for newer versions or if the documentation needs to be updated.

  • So I found that sr3 is now sr1, it was done to help tidy the naming up.

    As for my original problem it was due to me being connected to the PC during testing. via usb therefore using up the mav link port. Hence no mav link data could be written to the osd! Silly me.
    • how did you circumvent this issue? how did you write the mavlink data without usb cable?

      • You can write the parameter settings, and then pull the USB cable. As soon as the USB is pulled, that should cause the output to appear on the telemetry port instead of USB (the smaller PPM encoder CPU takes care of that).

        I'm not quite sure about 2 things though:

        1) Whether UART2 is still disabled in Ardupilot code on APM2 and

        2) Whether SR1 refers to UART0 over USB, UART0 over telemetry port, or UART2. Okay, it's probably not UART0 over USB, since SR0 is for that. So my suggestion - apart from looking the code if you can read that - is to try both SR0 and SR1, and look both at the telemetry port (always with USB pulled) and the UART2 port..

        • My issue turned out to be an APM:Plane 3.0.3 bug.  I reverted to 3.0.1 and everything worked as it should.  I reported the issue.  No idea if this will be fixed in the upcoming 3.0.4.

  • Hi,

    Go to initial setup, optional hardware, should see telemetry hit enable. Might help

    • I tried that.  It doesn't seem to be a button I can click.  I see it but seems shaded out and I can't click it.

This reply was deleted.