Minimosd stuck on waiting for mavlink heartbeats after firmware upgrade

I've just given minimosd the firmware upgrade to support Mavlink 10, and now it will boot up but will never get past 'waiting for mavlink heartbeats'.

I'm running 2.6 on an APM1 2560 and have made sure that my board is using mavlink 10. Eg I am using APM planner 1.1.92 mav 10 and it connects fine. The minimosd is one of the earlier ones - version 0.1

I have been using this osd with mavlink 0.9 for the last few months with no problems. It is just since the firmware upgrade that it won't work.

I have tried putting the old mav 0.9 firmware back on the minimosd, and changing the APM board to disable mavlink 10 via arduino and reuploading, but even that doesn't work any more! It still gets stuck at 'waiting for mavlink heartbeats'

I've checked that the wires are connected correctly from the telemetry port on the APM, and that they aren't broken, and have also checked (and reflowed) the pins at both the APM end and minimosd end to make sure none of them were loose.

I don't have xbees either.

Help!

Views: 2980

Reply to This

Replies to This Discussion

I'm in a similar boat. I don't have a cable to update the MinimOSD firmware, but I've upgraded to 2.6 on my APM (which is now MAV1.0). I haven't tried booting up with the OSD, but instead I'm looking for a way to revert to MAV 0.9 until I can get my hands on a cable.. Too bad there's not an option in Mission Planner to select which MAVLINK version to use..

I think we have different issues, but you can re enable mavlink 0.9 in your apm_config.H by uploading the code via arduino.

Feeling pretty relieved right now. It turns out my telemetry port pins on my oilpan were busted. Found some alternative pins on the oilpan to connect to and life is good again.

http://diydrones.com/forum/topics/broken-telemetry-port

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service