Hello. I have an APM 2.5 with MinimOSD. I can get my MinimOSD to function properly if my camera is unplugged. However, as soon as my camera is plugged in, I get great video, but no OSD text overlay. If I unplug my camera, me text comes back (with a grey screen behind it).

I've checked my cabling and everything appears in order.

I've reinstalled my firmware 2.0 and OSD Extra 2.1. I've also updated my character set. When the camera is off the OSD is functioning perfectly (no fuzzy or malformed text). It's like the OSD will transmit either the text or the video, but it won't overlay the text over the video.

I've also tried powering up the OSD is every possible order I can think of.

Any ideas?

Thanks!

Thomas

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • T3
    My gut tells me it's a bad osd, but that's just a gut feeling. Good luck.
  • T3
    You have tried toggling the OSD into PAL mode?
    • T3
      Are you using a micro minimosd? Not that this helps, but I have had lots of trouble with those little things burning out. My full size 3 yr old minimosd wrks great, lol. I have found a perfect 5v source is required for the micro to work well, I've ordered mine from Amazon. This sounds like a bummer of a problem.
    • Yeah, I tried that. It still did not display with the video image, and when I disconnected the camera the osd was scrolling and illegible.
  • Here we are 3 years after the start of this thread, and the problem still exists!

    I was using a 600tvl Sony camera with a 200mw vtx on a 210 mini quad, when I added a Minimosd micro. This was displaying fine until I started the motors, and the OSD disappeared! So to cure  this I bought an Echine 800tvl CCD camera and a small 600mw vtx. Connect it all up and I get no OSD display...unplug the camera from the Minimosd and the OSD displays perfectly on a grey background, plug the camera back in and the OSD is gone!

    I have tried twisting the video cable, to no avail, and I have tried powering and grounding the OSD and camera from the same point, but still no luck. The camera is fixed NTSC, so I can't try it in PAL mode, but it seems the problem exists in both modes. No mater what I have tried so far I have not managed to get the video feed and OSD to display together.

    Any new ideas out there????

     

  • T3

    I realize this is an old thread, but I thought I'd throw in my .02 as I just had this issue. I switched the minimosd to PAL and the problem resolved. The OSD and camera must both be in the same setting. Hope this helps someone. 

  • I'm having the same issue with my micro minimosd running MinimOSD Extra R800 on my large multirotor.  If I boot up with everything plugged in, no OSD.  As soon as I unplug and replug the camera, the OSD shows up perfectly.  Did you ever resolve, or just keep using the switch?  I thought about using a switch myself, but reverted to just plugging in the camera right before a flight (kinda annoying) instead.

  • Hey,

    Any updates there?

    Same thing happens with me.

    Tried everything, but overlay with video works only if I replug power on camera (600TVL Sony HAD)

  • I have dug around all the settings in the camera... :(
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @RoboticMasters: Monaco GP Circuit in the Donkey Sim (coming soon). Including buildings, tunnel and all! https://github.com/robotics-masters/sim-donkeycar-f1/tree/f1-tracks @diyr…
4 hours ago
DIY Robocars via Twitter
RT @breadcentric: Here are the details of #AWSDeepRacer finals: https://blog.deepracing.io/2020/12/01/aws-deepracer-league-finals-2020-round-1-schedule/ #awsreinvent2020 #AWSreInvent https://t.co/ovqsjp8V…
4 hours ago
DIY Robocars via Twitter
RT @breadcentric: #AWSDeepRacer League #awsreinvent2020 Open race is on Dec 1st - Dec 31st in three categories, 15 DeepRacer Evo (with LIDA…
4 hours ago
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars It's just something that's easy to track with chroma keying. I ended up using different colors on th…
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Nov 23
DIY Robocars via Twitter
Nov 23
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
DIY Drones via Twitter
First impressions of the Intel OpenBot https://ift.tt/36qkVV4
Nov 10
DIY Robocars via Twitter
Nov 9
DIY Robocars via Twitter
Excellent use of cardboard instead of 3D printing! https://twitter.com/Ingmar_Stapel/status/1324960595318333441
Nov 7
More…