MinimOSD won't show text when camera is plugged in, fine without

Hello. I have an APM 2.5 with MinimOSD. I can get my MinimOSD to function properly if my camera is unplugged. However, as soon as my camera is plugged in, I get great video, but no OSD text overlay. If I unplug my camera, me text comes back (with a grey screen behind it).

I've checked my cabling and everything appears in order.

I've reinstalled my firmware 2.0 and OSD Extra 2.1. I've also updated my character set. When the camera is off the OSD is functioning perfectly (no fuzzy or malformed text). It's like the OSD will transmit either the text or the video, but it won't overlay the text over the video.

I've also tried powering up the OSD is every possible order I can think of.

Any ideas?

Thanks!

Thomas

Views: 8526

Reply to This

Replies to This Discussion

Update to the latest beta. You must be using a high res camera.

I am glad I am not the only person with this issue :-) I've tried NTSC and PAL to see if that makes a difference and it doesn't. I am going to try a different video source to see if that changes anything - but I need to make up another video cable to try it.

What version is the latest Beta. I think I already have it loaded and it has the same problem.

Latest version is 2.1.5. On old versions you get osd or video not both. On the beta it works for me. I use a Sony 600tvl camera.

Great, thanks. I think I am only using version 2.1.3 so I'll grab 2.1.5 and try it out.

It turns out that I had already been using 2.1.5. After experimenting a bit the OSD works fine with the video output from my camcorder, but not with the output of the camera I was planning on using in the hexacopter. So looks like I need to change cameras :-(

Thanks Steven. I'm using a Sony 600tvl, as well. I'll try it tonight. This makes perfect sense.

Thanks!

Thomas.

Humm. No luck. I still get the exact same results. With the Sony 600tvl on, I get great video, but no OSD text. When I unplug the camera I get all of the OSD text, immediately. I reset the Sony 600tvl to the factory settings and I still get the same results.

My brother uses the Sony 600tvl with his minimOSD and has no issues.

Hardware problem?

Thanks.

Thomas

Before you switch cameras, try twisting the wires going from the camera to the osd. I had the same problem and it fixed mine!

Hmm, I have this same issue with another imu based osd, bought it a couple of years back but never used because I could never solve the issue, and the vendor would not take the unit back as they claim to have tested it to work fine before shipping it.
I suspect that some cameras output is too powerful somehow and this causes the problems, but thats just a gutfeel hunch.

I solved my similar problem by changing from shielded to unshielded cable between the camera and OSDMinim. I have no idea why it helps... (I would have guessed that shielded would be best; but not in my case...)

Thomas,

I am having the exact same problem. Video and no overlay- unplug the camera and you get the overlay.

Did you solve your problem? I sure would like to know.

Thanks

farmertom

What I did was twist all camera wires and I bypassed the osd with the positive wire and powered the osd with the 5v on the other side. So only video and ground is connected to the osd

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service