"Missing RC rev param" error when I select Radio tab APM Planner 1.0.99 for my Quad X setup.

Any idea why I am getting this message?

I cant seem to get the motor output mixing right. I do have all controls in my (Futaba T10CAG 8 Ch) RC Transmitter working and responding correctly in all settings on Mission Planer on Radio setup tab in correct sequence, but the actual relationship on the motor outputs are all over the place.

For example it all beeps up OK and no motors running when powered up.(Yes ESC calibrated all ok) Nothing happens with the motors with any of the sticks. Then when I turn the VR(B) knob up CH8 (Radio 8) then three of the motors run at full speed. Then using the sticks in different position combinations the other motors run is different sequences. I think I'm not far of getting it right, but Id like to get rid of the error before taking lots of time setting up PIDs etc.

I then tried using the CLI to set motors up instead and soon as I clicked Motor in setup they ran full blast, then stopped, beeped all over the place, jittered weirdly and then smoke can from one motor. I managed to unplug it before it was fully fried. Now Im very nervouse to try CLI again.

Any idea why this error message?

Missing RC rev Param.JPG

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Have tryed this "Remember, to use the new logging format on the 2560, you need to erase it at least once to format it"

  • (7hrs later) its something to do with the 8 channel receiver.  I at one stage used CLI so set up the radio and some how this doesn't see 8 channels and only 7 channels. So I omitted channel 8 wire and the error didn't show up when I select Radio tab on AMP. However then nothing at all worked , not one motor movement. I reinstated Channel 8 and now we are back to motors working but all over the place and that error message still there.  I get various combinations of motors running when i change the receiver outputs into the APM. Though Channel 8 seems to be needed to get power in most cases, I did once have it that pitch on its own would run one motor without Channel 8 dialed up. .. I got a feeling ti will work once i figure which receiver wires go to which pins in the APM. Its a mystery so far.

  • Have you tryed to download the complete mp99, and run it from the new 99 folder?


This reply was deleted.