Hello to you all,

 

I have run into an issue with the auto flight mode, when I put the plane into auto mode the plane will turn towards the first waypoint but will start to descend (approx 50 meters up at that point). I had let the plane go as long as I could to see if it would recover to level flight, about 10 meters from the ground I had to take back control as it did not look like it would.

I tried the other mode, which is stabilisation, this worked very well in today’s flight that was in 10 mph+ gusts of wind, so I know that the APM is working very well.

This makes me think that there was an issue with the altitudes set in the planner, so I started at the beginning with the planner, I set the home location and checked that there was a home altitude set  (approx 90 meters home alt), I checked the verify altitude box and had no red boxes showing (WP's all set at about 40-50 meters), sent the plane up again, the same happened, stabilisation was fine but auto would turn the correct direction and descend.

I then started over again, set the altitude of the WP's to some 150 meters (first flights 40-50 meters) to see if this would change the decent activities, and however it did not.

I'm confused to why this would be, it is only a guess, however I think there might be a miscommunication on the starting altitude so the plane thinks it is way to high at the start of the flight in the auto mode, then starts its decent to the first way point.

 

Any thoughts or ideas what to check or try?

 

Regards

 

Martin.

Views: 732

Reply to This

Replies to This Discussion

No, all altitude calculations in APM are relative to starting position. it uses a mix of GPS and barometric data, all offsets by starting altitude on the ground.
What version of the code were you using? I think there is a bug that's causing this (we see it under certain circumstances in the sim) but we're having a hard time consistently replicating it.

The APM code is the Dec 13 code which I got yesterday after the Dec 23 code was pulled ref this Link.

 

This is the code I used today.

Hi Johann,

I understand that you can change the mix of pressure to GPS ratios for altitude. I believe that the standard settings are 100% GPS, but you can set say a 50/50 mix if you would like. I always make sure the altitude is shown in the home location when using the planner setting the home position, I have seen that the altitude will not always show when selecting the home position. Not sure why, but it will with a few clicks on the home location coordinates.
Johann, I believe that the altitude set is all relative to your starting altitude, so if you are at sea level at launch and ask your drone to fly at 100 meters you will be 100 meters above the start point. Now if you are back at home, which is some way above sea level, and you wish to fly at 100 metres above the ground your home location is what ever that altitude is there and that will be 0 metres as far as the mission planner is concerned, so you will still only be flying at an altitude of 100 meters.

Same here

Before I switch to Auto I always have to get the plane in the relative vicinity of Waypoint 1 or else it will descend at idle to the ground.

When I switch to AUTO the throttle goes to idle until reaching the defined radius around waypoint 1, then the power comes up and flies the sequence.

That's a bug we'd fixed in the Dec 27th code, but I seem to have introduced a few others so I had to withdraw it. Please stay tuned...I'll try to get a fixed version out this week.

I can confirm that I saw the same issue with the Dec 13 code. After reverting due to the aforementioned issue with the Dec 27 code, I did my first ever flight test with full-auto mode.

I had a 4-waypoint path set up and after switching from Stabilized mode to Auto, the aircraft descended from around 50m AGL to the first waypoint. I watched it very carefully as it was the first test, ready to recover, but at the first waypoint having descended to around 10m AGL it went full throttle in a climbing turn to waypoint 2 before levelling off at the prescribed 100m and flying the remainder of the mission without issue.

We've got it fixed. I'm just dealing with one last different bug and then I'll release a new version, probably tomorrow. If you're in a hurry and know SVN, you can pull it off the repository now. (The last bug only affects simulators)
The fix in the MediaTek GPS library involved some architectural rejigging, which broke AP_GPS_IMU, which is called in HIL mode. That reminded us that the IMU input from the flight sim probably should not have been lumped in with the GPS libraries anyway, so we did even more rearchitecting. All that is fixed in 1.5, which is now in development on the APM trunk, but we haven't ported it back to 1.0 yet and it's proving a little more complex than I had expected when I gave myself 10 minutes to do it yesterday ;-)

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service