Newer versions of Mission Planner  (1.2.50+ iirc) need some additional mono packages to work on Ubuntu. They're only available in Ubuntu Precise 12.04 and above though. You can install them like this:


sudo apt-get install -y mono-runtime libmono-winforms2.0-cil libmono-corlib2.0-cil libmono-system-web4.0-cil libmono-system-management4.0-cil

If you have problems seeing the serial ports, make sure you're in the dialout group:


sudo gpasswd --add $USER dialout


(you'll need to log out and back in again to be sure any group changes take effect)

Views: 7522

Reply to This

Replies to This Discussion

just do a

sudo apt-get install -y mono-complete

That installs 109 more packages than you actually need though :)

Good morning,

I running 1.2.76 with additional packages and the add $user without problems.

However, today MP ask to update and installed 1.2.80.

After this upgrade I couldn't start MP again. Mono failed with mono MissionPlanner.exe': No such file or directory.

I reinstalled 1.2.76 and all working fine.

any Idea what could be wrong???



Hi Dieter,

Same problem with me. Right click on Mission Planner exe, and run with Mono-Runtime. Does not open or respond.

From terminal, it says "Mono failed with mono MissionPlanner.exe': No such file or directory."

It was running until last time, I just installed MP again today as I reinstalled ubuntu 12.04. What is happening here, any idea?

I don't know, install 1.2.76 and it may run and wait.

sorry thats all I can say

Well, I found a hack/ workaround.

Went here, downloaded Mission Planner 1.2.54 (old version). This opens with Mono. Asks for update, say yes. This installs all the latest libraries (be connected to internet).

This opens with Mono-Runtime or Mono-terminal.

I think there must have been some recent update that prevents us executing the latest version (from zip) with Mono.

@ Michael, could you confirm this for us please? Thanks.




I encountered the same problem. After upgrading MissionPlanner on a virtual box it forced me to install .NET 4.5.1. What I did to get it working with mono was removing the old packages, adding this ppa to your repo, update and install mono-develop. Then it works again!

Have fun!


I tried it with all kinds of different versions and can't get Mission Planner on mono to work. It used to work, though, but can't remember with  which version. 

To be honest, I don't understand, why they don't develop MissionPlanner for linux natively in the first place.

I mean, come on, we're not dealing with iphone fanboys who are too technophobe to do anything besides gaming on their device here. I can't really imagine someone who is interested in technology will run windows as his main operating system. This is like insisting on using a tricycle with supporting wheels although they got a car as a present for free....

OK, but enough of the ramble. After trying mostly everything to get Mission Planner to run on my netbook on debian, I hope to find some more tips here. Tried virtualbox, which doesn't want to compile the kernel modules it would need to run, qemu, which does seem to need major loophole jumps to get online, wine and mono, which tells me about fatal errors in the mono runtime.

There must be more sane users here who just want to get this to work without having to spend weeks of their time with unconfirmed trial-and-error setups and of course without having to boot windows.

So, it would be really essential and important to have a sticky or a guide or something somewhere accessible where we could learn how to get Mission Planner to work. It's not that linux users are a minority or something. Windows users are just too ignorant to understand that the computer they are using is actually able to work fine, they just don't want to hear it, and everyone else including capable develpers is submitting to this nonsense by supplying them with more programs for their toy "operating system" instead of partaking in some real technological development which is only really possible in an open-source environment.

You can flame now all you want, you know it's true, though! :D


can only agree, but it will not change, sorry

Just now tried again with Mission Planner 1.2.55 which was the most up to date in the download section. That's another thing: Why aren't the newer versions available from the download section?

1.2.55 seems to work on mono when I don't update it. At the first try I got tempted and hit the update button, it then updated to 1.2.87 but didn't start anymore after that.

Where can you still download 1.2.76? Can't find it as a direct download. Only the link to the "latest" and in the googlecode download section there's only the sais 1.2.55....


This link will get you to the latest Mission Planner: MP Link



Thanks, but I'd need not the latest, but specifically Missionplanner 1.2.76 because this is reportedly the latest that works with mono...I have the latest running fine on my windows partition, I just don't like to start windows to use missionplanner because then I can't use the rest of my programs...:)

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service