I'm sure I have had this problem a while back, but can't recall if it was a software bug or something else.

Anyhow, after updating Mission Planner to the latest update (1.3.9) it hangs if I perform a manual "CHECK FOR UPDATE" and if I load the INITIAL SETUP and INSTALL FIRMWARE, it displays the "There was an unexpected error" message.

Any ideas what the issue maybe.

MP is allowed through virus and firewall protection and displays the same error even if they are temporarily turned off.

Many thanks,

Steve

Views: 5879

Reply to This

Replies to This Discussion

please post a screenshot of the details

this is a firewall/proxy/internet issue.

 

Mp cannot access the internet

I have my Firewall and virus scanner off, any other ideas?

Its used on a PC that does have internet access as I am using it to post this message.

It was working fine before the latest update.

Many thanks,

here is a ms article about it

http://support.microsoft.com/kb/915599

 

Thanks Michael.

I have tried all-sorts but still failing.  APMPlanner2 works without issue, but I prefer MP.

I even installed an old version which started the update process fine, but then stopped displaying the below error.

Are you 100% its something my end and not an error in the program.

Thanks again.

if it was a programing issue, I would see a lot more cases of it, which I don't.

 

the only thing I can think is the system proxy is not working. and you use something like chrome etc that hides that.

 

does internet explorer work?

are you sure you have .net framework v4 installed?

I have the latest v4.5.2 installed which I have removed along with MP and reinstalled both again to make sure, still same issue :-(

I rolled back and installed version 1.3.0, no problems at all.

Downloaded latest firmware etc without issue.

Performed the manual upgrade from "CHECK FOR UPDATES" and it again upgraded without issue to version 1.3.9.  It has now stopped working again :-(

Hi - I to have just had this problem. I needed to replace the micro USB on my board which I did and just so happened to upgrade MP at the same time. I keep getting "There was an unexpected error" and 'Bad Firmware" when trying to upload hex profile. Thinking I had not done a good job on the replacement USB I have plugged in my new HKpilot 2.7 and got the same result. I have swapped out the leads as well.

I have the latest .net framework installed.

Windows 8.1 professional

There must be a bug preventing connection as everything was working fine before the upgrade.

Reluctantly looking at using an older version just to get me back in the air.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service