Mission Planner Maps Went Low Res

I've been using mission planner with the default maps it's installed with.   They were great, high resolution and recent imagery.

Today I tried a few other maps, and when I went back to google, I no longer get high resolution maps, or it's using a different map source or something.. 

I uninstalled, removed the folder from ProgramFiles(x86) and reinstalled from scratch, and the maps are still low resolution. 

Does anyone know how to resolve this issue?  Are there settings in another folder or the registry, I could erase to start mission planner over completely from scratch?  Or, is google not the default map source?

Thank you.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi...  Still low resolution using the Google Maps with Mission planner.  My wor around has been to use the BingHybrid map but prefer to see the Google ones working again.  Is anyone else having this issue with v1.3.32?  


  • I agree...  same problem fr me.  I'm surprised this thread isn't loaded with comments for same.  Bing has good source in hi-res (not as good as Google was...) but still curious what happened to the map source?

  • I tried it on another computer I haven't changed any settings on, and it is different now, too.  So, maybe google updated the imagery for my area. 

This reply was deleted.