Mission planner over HK bluetooth..

Hi to all... Had my multiwii pro board running multiwii and connected to pc over HK bluetooth module (HB01). After going to megapirateng couldn't make bluetooth work in ANY way!!.. tried for hours changing ports, settings etc.. until i found that:

Having mission planner trying to connect (115200) and having bluetooth on Serial_0, countdown 15 seconds and then connect main power on the board... then it connects fine!!!

Any comments suggestions on that?  Thanks in advance!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • After receiving 3DR all is ok now :) .. BUT i also noticed this delay (this time automatic) when trying to connect to the 3DR module.. it takes at least 10 seconds and after this starting establishing the connection... probably on bluetooth case a delay parameter is needed...

  • I have the same issue. Never had this issue with an older version of the MP.

  • Very good Information!

    I believe many People have frustration on this issue, i tried for a week now and had one Connection.

    With Your guide: wait 15s after pushing Connect, then Power on the AIO Board.  This Works!!

    Now hopefully the team of good programmers out there could add a code that fix this issue. 

    Tnx a lot !



  • go to the discussion here http://www.hobbyking.com/hobbyking/store/uh_viewItem.asp?idProduct=... 

    I described my trick

    hope It will help Bertzilla

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25