I have a 250Quad I just built, flys just fine.  All other aspects of mission planner work fine, but when I try to see any logs, all I get is endless streaming garbled after I hit connect.  It will never stop.  (I'll paste some in here at the end in case it means something, searchable, etc) 

I CAN get telemetry logs (.rlog and .tlog), somehow, they just appears in the default folder. But no .log's

When I try to get a Dataflash Log via this method, I get this: (error receiving log list)

3691192707?profile=original

It is HIGHLY likely I am just not doing something right, totally new here. I've reached the limits of what google and searching have found on this issue. Help!

MP 1.3.2 - 1.155430869

Init ArduCopter V3.2.1 (36b405fb)

Micro HKPilot Mega Micro Sized Flight Controller and Autopilot with Leads 2.7.2 (APM)

3691192631?profile=original

APM Planner 2 just is empty. 

3691192720?profile=original

♦NOTE* Please click connect above
CLI Works only on first connect of power, log download only over USB
Newer versions only support log download via mavlink, please see the flightdata > dataflahs logsOpened com port
Init ArduCopter V3.2.1 (36b405fb)
Free RAM: 1995 FW Ver: 120
load_all took 28440us
3No dataflash inserted3Q?3Calibrating barometerz?QCA3barometer calibration complete3GROUND START?Init Gyro* Q?*
Ready to FLY <-;S9}uYD! ! !d
<-*P ublox >&W|a!=$}9?#U;=OO0qN:09b8pJ
R27v"D<-qFA~YDGZ /!/!/! Gc3uA#<-*28>X6$bF$ : 70 ?>B6; ! 0=[ $RAI! #"%e%=0@ 9@ 9b8p#J??) \>
#< | $W<0 : . ;%o&pr!7'Q0 7 (<-lI~) YDRh*/ ! / ! / ! LcQ+mY% , *#-GN6$$F!%??0.> n=?/0 !X!/=1$0I [?2 #*3>
9>#O09!b84JG!?G!?Q8>
<>5 '<JJ; 6C7zy8<-AEQ} 9YDGa: / ! / ! / !Dc;U<*L=PK6$F%&O?0c»wS?
0!%=6A$yQsHB#cC+A>{=O0909!nDJ>»
#=E*<me;/
FG?HQt?I<-8Y~qdJYYD\gK/!/!/!OcaLMM*N 8W7$F 97080 >V(hPhQ!T =?R$xY' S#p\TGy>ZO0T0 9b8UJ7?
#>u=wV;;QWXXH
Y<-$a~ZYD(;X[/!/!/! ?c\MN! ] *A_'8$FV: ?0W-»_>Hc'a!8$FVO>?b$aHc#kdJV>309n:b82eJz?z?Ga>
=Nf }RN;8>ghb2iQ! s?j<-i}PkYD\Vl/ \GcnmMdn*8oxvfe9$mF A?0Fp>: +qr! 8$F/?_s$QGi6?t#<-au<-L>Dv60Tn:b8
TvJG>G»g=w>;>xlyx<-?z«-{q~{%YDff. | |/!/!/!JcA}M~*fToT:$/Fv>?0>-A!9$[Fv, : z0?$ {q#LPax>80T09i : IJR?R?>=) ?<-;L=Sld! nQL?<-x}YD\/! /! / h IcmMg*un{x: $F\b?0>y! : $?F\Aa0I$ (yt#1-8X+>9009! Op} ?p} ?33>=I ;=Q0R'O (?<-~7! YD/! /! /! JbPM*0~: $F [?0<-4>3s) !h G;$F I YWAB$b#! I#! : aG>: 0909! %Jh? h?\>=l?r
;U>=;XJ4 !hQD <-\~U#0YDRf *>L>S<L<a; 95DȣU/! /! /!GbM*>: $Fu5B>s7n! " ;$FuAIR$O?0#&#g:#SiO>;0 :09!mcJ=
?=
7>=gocOCK9MB: : 5=gi9<#?«-~%YDQ /!/?!/! IbCM"Z*R/P>;$FFU5Bw>0SA! %<$FGA+$>#7%] 7% !lc">
9<0 90 9b8d} J5?5?»ocOCK9MB: ! :<S1HL%8Q?<-} ’ YDG x/! /! / !NbxMK*2; $F35B<I, >DbFk! sx<$?F I *A3' $?#A' A 'Dp>s?<0 9n: i : J\?\?\»'ocOCK9MB: -: T: !<H}p3S'd<-~ }x-)YDz C/! /! /! IbkM*3 (<$F 5Bm>|<-R! )<$F B$ 6 J#3# J) b J) p>' <0 T0 9! J #>
#»>hocOCK9MB: (a:N«* A) ?Qx?<-<-} 7>+eYD! /!/!/! yLbMu*VC<$F~45B | >hj<! *1=$F~4 ’ Bl$=?#f+7f+B7r>. . =0qN: 0 9b8Y4 J??=
»ocOCK9MB:p9&<w) ' z+J?«-Q}H-;YD!/!/!/! ?Lb0Ml*Y}<$F<5By?>-L! , 1=$F<6B) $lr?#o-b’
o-u>X=0T3b8UJk>k>(»ocOCK9MB: .T:e;#hK-#QQ?*-}N/YDG! (B/ ! / ! / !DbYMQ*#+b<$F/5B9£>,a!E/=$F-CBC?$MT#v/\<-w/
yx>| =00 9b8A2J»»AocOCK9MB: {9q;YxB/XC <-} IV1FYD (!"/!/!/!Ea#MY$*i %k<$F05BS>jD ' (!0p=$F0JBj)$2*#~lGg+~lAx2>=03i : , JG>G»>-ocOCK9MB:K9M1 ;F? . 5/) lrOQ"l <-~R|2_3YD"
3/!/!/!Na4M05*u6<$
F5B?D7>o8I9! ,3]=$FOBi~:$\V;#3<3y>q=03b8=J?»?>s>ocOCK9MB:il: : %7?=033A<-~9Bf5YD"C/ ! / ! / ! GabJDME*9FH<$Fj5B?G>0DHhI! 41=$FjSBJ$ L?K#SL5z>w=0T! !vMJ >
>\7>pNocOCK9MB: j + : : rO, Ph5A?QQ*?R<-} Sn7] YD”+T/ ! / ! / !Na4UMyV*W*=$OF$5BU?X>Y0Z! 7 }=$-F$XB [$vq\ #7]7|>$=0 !b8AJQ>£>?=J_Lf-19d: ! : i: J' | 7a7#?b«-y-| ~hcw9YDe#*d>L>S#<L<a; 95D»8e/! / ! / ! PafMg*h£=$FN: SBvi>vjk !m9=$0FN7\B*l$LHm#94hn9 {>
=03b8W8oJz?z?>G=eApLf-19d: : :n&q?r90sQA?t<-g~u~;rYDff#v/! /! /!LaAwMx*oyHl) >$F>5B?z>c{ | ! : >$F>'Bb}$?~#;-[ ;uzV>=093b8C JR?R?ff>G=yLf-19d: +9J: ss (; ;Q$<-X} =YD\#LK/! /! /! PaM*6V>$F*-5Bs>ye/!U=>$F**bB $gD#==#w4>=09! ! ~Jff>ff>(>=p=Lf-19d: OIL: : P!=T<-) F~ [?OYD#D/! /! / !KaM <*q]>$F1 5B?>j !»$FdB$?#??pt}>=0909b8J\?\?G>=Lf-19d:vW:W:Q<D) ??QJ?«-s4~eA
YDzT$/!/!/!M'zMOy*UH!>${F85Bu> wT"!=A>$FdB$)#ATA?lt>=0909i :J)\?)\?>£=Lf-19d:X9$5;TnlAh?«-y)}CfYD($/!/!/!O'%M*H=$bFHa5Bp>F!C>$tFHUcBY$ZyLa#CCjv:>'=0T3b8HJGz?Gz?>
=Lf-19d:b:U5:ud9C(Q?<-7~EYDL$X/!/!/! J'yM*y=$sF(i5B*+>VS$!%E1>$ZF(hfcB!$e?y |#E?Ev>=09! ! J??Q» \=Lf-19d: 912;<hAE?«-~G$YDp$/! /!/!Q'0MA*sH0=$F <-5Bah>53! }G=$QF <-hbBL$S=?#G;GEx>k=0?909b8 (Jff?ff?Q» \=Lf-19d: ] 7 : = : |<uIG[3PreArm: Bad Velocity?Q?<-<}xIYD %/!/!/!O' /M4*KZ<$FF>$.d<-! I=$UFJfdB$3C iD #IIy?>=0n:b8kJ\?\?>u=Lf-19d: (: :uF?dQI/?«-z ’ }uKYDp=j%/! /! / !D'M*H~«k$F [ES<>3E3QQ!dKa<$nF07bB$l (O#KKx*>=0T09b8sJ00 >u=V9X#9q:v>:4;C/(PYK3Q?
*-/~$Mj YDp=%/ ! / ! / ! E'BMDu*wO/#; $FF"FXb>c, !M; $FF"0bB$SOZ#M}M-\ve0>=0 90 9i : J%0%0 >u=9x# 9q:O:kY;D;aN/
<-07~!Q<-0uYDz%C*>L>S%?CL<a;95D»P/!/!/!E'M\*] 5:$?F$E~!>c~"#!NO:$F$0'Bc?$$_8)%#OSO#v+>c=0T!?i : [’ Jff60ff60
>u=Zf(9X#9q:<$:=;')Zt*2iPL+Q? ,<-?}'-QYDff&./!/!/!sB_/M?0*1lp>9$Fb$3E2>2A34!Q9$Fb$63aBM5$q0y6#Q67Q|uF>=0qN:!!J8JzD0zD0R>u=mZ99X#9q:X::=:7;qR|«-G}!=SYDUSp>/!/!/!O =?»M0*6AE9$F(’ D7BXKD!5S8$Fh(,%aBE$G ]F#TpGTAv>H=0T09b8uHJ
30
30>L=EI9X#9q: 9: J-Ky<-TA?LQ0M<-qO~ ,NUYYD\sO/ ! / ! / ! L_PMaaQ*R2N] 9$<-F+A-»S>Td~U!U
8$F+6>cBqHV$TO_W#VgXV! VWz>=009! YJff S0ff &0R>L=BZ9X#9q:pk9: F1 [<-*\pN$v4] <-W~AWYD {N&R_/ ! / ! / !N_( Mia*bpZW8$F.B-j c>sde!W7$5F. , %cBf$W»g#XLhXv>5=009! iJz$0z$0>
#=wj9X#9q:X: f: kr?19+X?mQ?n<-p_}GoY<YDG&)p/ ! / ! / !B_6qMr*kst] t8$lFV0 B0t>fuiv!vY(7$VFV0"SbBlw$_+x#ZyZAz>=0 0 9b8zJG*0G*0 z>
#={ 9X#9q: ,9;F| }) 3Z, ~<-ag}u\dYDp? ’/!/!/! I_%/M* : 0f7$XF<lB?>F! [6$~F<l"0bB$g7#'\n'\' I zc>=03b8JQ (0Q (0z>
#={ 9x#9q: $ :M: lH;\b$ Q6<-gOo} AYD (sV/! /! /! G_M/*sj017$PF (1B>8R’ !A]k6$F(16 saB$oL#/AL/Ax>=0!i :TJ00R>
#=fm9X#9q:A:5;CA}«-Hw~W' YD 1 h/ ! / ! / !D_n A!u*luA8$9FxlB>?Z?!_z6$FxlJjcB$jwA#9'?9'xc>=0909b8J o
?>
#=GF9 ' X: # : f: XOM' Q?<-5} <-bYD33 L_/AH*
8$%F1XB1>' !b6$FlAUcB$f#AbnBbHy>=03b83dJGa?Ga?33>L=fGF?9'x: 9G:Ub?<-, $~ !dYD' 1/! /! /!FAA) *%8$F1=B8>6!cY7$gFlh;dBA$Uxg#IdYIdvP>'=0 : 3b8J(? (?Q>L=3GF9'x: SF: 3: «-?H]d?QB«-w}r>*fEYD 'Q) *>L>S'<L<a;95D»/! /! / !EAAr*]L99$F\4B~N>=W!e7$AF\4hdB->$#QfeQf<v>=0909Mj J{ .>{ .>£>L=?
GF9'x: +9: TefA?*-~2hYD (/! /! /! IAAz*Xg89$F5B/>- ;i!g8$F6rbB2$U_#YhLVYh! w>=0T09J»p>

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Where is the CLI_Enable parameter. I can't find it.

  • Search for the cli_enable parameter, change it from 0 to 1, and access to terminal works.  It was not removed, it was disabled by default.

  • Darrell, did you ever resolve this?

    I have a new APM build. Running the most recent mission planner, plus 3.2.1 on a clone APM 2.8 board everything is peachy and the thing flies fine, GPS works all that good stuff, but I'm having the exact same problem you have here. Under terminal I cannot connect at all, it says what yours says. So I try going to dataflash logs and that doesn't work, either, with the same error you have.

    I've googled about this but cannot find a resolution, as few people seem to be reporting the problem. I'm having a hard time believing my board is bad, since it does save settings, calibration, etc.

    Now, this is all through USB. I don't have telemetry radios in place yet.

    Admittedly, I've not yet done anything on the tab in the first response (at work now), and haven't fiddled with this:

    MissionPlanner_LogBitmask.png

    • I concluded it was just a board board as well. If you find out another way to get the logs off, lemme know and I'll do the same here too.  

      • OKay so same issue as you. I cannot save bitmask, it just defaults to disabled. If I change the setting and hit write params it says save was successful. If I then refresh params it appears there as well, but if I disconnect and reconnect and pull anew it's back to disabled. Interestingly I did actually get a single log to pull up (just 6 lines long), but it showed up and I could even load it. But that only worked once. Now bitmask is just always disabled.

        I was able to save the RTL elevation.

      • I will. I figure the "Ah, Hobbyking" may have affected me, too, though I bought from Ebay. :) If I can get telemetry going shortly perhaps that will cover me for the most part.

  • What's your LOG_BITMASK setting? I was having the same problem in both terminal and through mavlink/data flash logs, I changed the setting to Default + IMU to get some vibration readings and the terminal option worked. The most recent set of default parameters I loaded left LOG_BITMASK empty.

    • That's the stupid thing, I can't write any new values for LOG_BITMASK's setting.  Even though it says it's successful updated parameters, and it writes without errors.  It's gotta just be a partially bad board because I have another identical Micro HKPilot Mega Micro Sized Flight Controller 2.7.2 and it CAN write figures to LOG_BITMASK and then I can download logs as usual.  Of course that board has it's own little unique problems too.  Ah, Hobbyking.  

  • Admin

    @Darrell,

    The CLI has been removed from v3.2.1 to conserve memory space.

    You can get the tlogs and data flash logs using MP Link

    Regards,

    TCIII AVD

    • As I said in the post, I tried that method as well, that's where I get the error "error receiving log list"

      I have the latest version, : 1.3.24 build 1.1.5574.33902 ArduCopter V3.2.1 (36b405fb) 

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…