Mission Planner Terminal Test Compass

I cannot get the compass test to work in Mission Planner. 

The mag is working in HUD and is enabled etc. 

What am I missing?    Is this a MP issue, a setup issue, a mode issue, serial, baudrade, a stupid user issue?

Mission Planner 1.2.35 mav 1.0 and ArduPlane V2.70  (ArduPlane V2.69 has same issue) and  AP 2..5+ board.

Here is how I reproduce problem:

Connect power via usb, open Mission Planner, after boot finished, connect, etc click on Terminal.

Display on pc shows init Arduplane V2.70 and command list as it should

type test     OK  get test back

type compass

Mission Planner gives no response and hangs.  Click Terminal or reboot etc to clear the hang

 

If I do the same thing as above but...

type setup    OK   get setup reply

type compass    then I get the results of the current compass data  => OK

 

Using the Ardunio IDE (for Version 2.69 Arduplane) and terminal mode for CLI then:

type test

type compass      gives the current compass data....  so Arduplane code and AP2.5+ board must be good.  but see next..

 

At one time the "test / compass"  actually worked in the Mission planner with V2.70.???? Don't remember the sequence of events.  Then it quit working again. Also, at one time I could not get CLI Test / compass it to work in Arduino IDE, CLI

Doing a little debug in IDE when CLI test compass was hanging the call toe compass::init() never returns. (print statements before and after the call)

 

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I have some more data.

    I am using the Windows version of everything - Windows 7 to be precise.  (This may be one clue)

    Using Mission Planner: (workaround)

    Click [Terminal]  (note board starts the reboots but Mission Plannerl puts it into CLI mode (most CLI commands work) but test / compass does not.  some others do not.

    In the main CLI menu Type  "reboot".   This starts a reboot.

    As board starts to reboot, hit Enter three times.   AP should go to CLI mode.

    Now  test  / compass and other CLI commands seem to work OK.  

    Using Arduino IDE:

    Go to Tools,  Serial Monitor.    Note that the board starts to reboot.

    Hit Enter 3 times.  This puts the code into CLI mode.

    Now here is the trick.  Note at the bottom right of the  Serial Monitor window are the options for the Enter key.

    * That option has to be "Carriage return"   for the CLI interface to work correctly  (Using Windows PC)

    If that option is set to "Both NL and CR  the test compass completes but the Heading, xyz and offset data list does not start it's listings   (Probably because NL starts test, CR stops listing???) 

    If that option is set to  "NewLine" the the command for test compass does not work

    Conclusion:  (Supposition on my part)

    Mission Planner:   Clicking terminal seems to send the three Enter messages to the board during bootup but somehow does not set the "Carriage return"  option.   Doing the reboot,  then hitting Enter three times seems to set it up correctly. Seems to be a Mission Control software issue.  Apple vs Unix vs Windows Enter key differences?

     

    IDE:   Operator Error.   Operator must set up Serial Monitor correctly for the ArduPlane code to work correctly.

  • Hi, Dennis, I have the same problem, but on APM 2.0. Some help to solve this?

This reply was deleted.

Activity

DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Monday
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: Another incident: https://t.co/G1pTxQug6B
Oct 23
More…