Mission Planner Terminal Test Compass

I cannot get the compass test to work in Mission Planner. 

The mag is working in HUD and is enabled etc. 

What am I missing?    Is this a MP issue, a setup issue, a mode issue, serial, baudrade, a stupid user issue?

Mission Planner 1.2.35 mav 1.0 and ArduPlane V2.70  (ArduPlane V2.69 has same issue) and  AP 2..5+ board.

Here is how I reproduce problem:

Connect power via usb, open Mission Planner, after boot finished, connect, etc click on Terminal.

Display on pc shows init Arduplane V2.70 and command list as it should

type test     OK  get test back

type compass

Mission Planner gives no response and hangs.  Click Terminal or reboot etc to clear the hang

 

If I do the same thing as above but...

type setup    OK   get setup reply

type compass    then I get the results of the current compass data  => OK

 

Using the Ardunio IDE (for Version 2.69 Arduplane) and terminal mode for CLI then:

type test

type compass      gives the current compass data....  so Arduplane code and AP2.5+ board must be good.  but see next..

 

At one time the "test / compass"  actually worked in the Mission planner with V2.70.???? Don't remember the sequence of events.  Then it quit working again. Also, at one time I could not get CLI Test / compass it to work in Arduino IDE, CLI

Doing a little debug in IDE when CLI test compass was hanging the call toe compass::init() never returns. (print statements before and after the call)

 

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I have some more data.

    I am using the Windows version of everything - Windows 7 to be precise.  (This may be one clue)

    Using Mission Planner: (workaround)

    Click [Terminal]  (note board starts the reboots but Mission Plannerl puts it into CLI mode (most CLI commands work) but test / compass does not.  some others do not.

    In the main CLI menu Type  "reboot".   This starts a reboot.

    As board starts to reboot, hit Enter three times.   AP should go to CLI mode.

    Now  test  / compass and other CLI commands seem to work OK.  

    Using Arduino IDE:

    Go to Tools,  Serial Monitor.    Note that the board starts to reboot.

    Hit Enter 3 times.  This puts the code into CLI mode.

    Now here is the trick.  Note at the bottom right of the  Serial Monitor window are the options for the Enter key.

    * That option has to be "Carriage return"   for the CLI interface to work correctly  (Using Windows PC)

    If that option is set to "Both NL and CR  the test compass completes but the Heading, xyz and offset data list does not start it's listings   (Probably because NL starts test, CR stops listing???) 

    If that option is set to  "NewLine" the the command for test compass does not work

    Conclusion:  (Supposition on my part)

    Mission Planner:   Clicking terminal seems to send the three Enter messages to the board during bootup but somehow does not set the "Carriage return"  option.   Doing the reboot,  then hitting Enter three times seems to set it up correctly. Seems to be a Mission Control software issue.  Apple vs Unix vs Windows Enter key differences?

     

    IDE:   Operator Error.   Operator must set up Serial Monitor correctly for the ArduPlane code to work correctly.

  • Hi, Dennis, I have the same problem, but on APM 2.0. Some help to solve this?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
15 hours ago
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
20 hours ago
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
20 hours ago
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Monday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Monday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
More…