Mission Planner update failed

I have tried to update Mission Planner 1.2.97 build 1.1.5167.24804 and get the following error message:

"Update Failed File downloaded does not match hash: it-IT/MissionPlanner.resources.dll"

What does this mean and what should I do to correct it?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I've been trying to update the firmware on my mediatek GPS with Mission Planner 1.2.98 build 1.1.5187.14200. This involves uploading custom firmware to the APM prior to the update, however, there is no option on the initial setup/install firmware screen to select a custom firmware image. Is this an oversight or will I have to roll back to an earlier version to get this functionality?

    • Developer

      you need to enable advanced mode.

      • Thanks very much, Michael. (I don't do this very often).

  • Developer

    give it a day and try again. this is usauly because of a corrupt download/proxy server

    • I tried to update today from 1.2.96 and get the message "update failed file downloaded does not match hash". Will try again tomorrow.

This reply was deleted.


Santiago Perez liked Santiago Perez's profile